codeblocks install problems under ubuntu 7.10

If you are trying to install codeblocks under Ubuntu 7.10 are you’re seeing an error message along these lines:

The following packages have unmet dependencies:
libcodeblocks0: Depends: libwxbase2.8-0 (>= 2.8.7.1) but 2.8.4.0-0ubuntu3 is installed.
Depends: libwxgtk2.8-0 (>= 2.8.7.1) but 2.8.4.0-0ubuntu3 is installed.

I had success following the instructions here: http://wiki.wxpython.org/InstallingOnUbuntuOrDebian

Works like a charm!

While you are at it, search for “libXxf86vm-dev” in synaptic package manager and install it to compile the GLUT wizard project.