Can't use ofxTimeline with 0.9.0

hi all!

started using OF few weeks ago and loving it! definitely seems like the best tool out here to create cool GUI.

i’m having troubles with ofxTimeline. I’ve cloned the repo and the addons from github as it’s said in the video tutorial and installed OpenAL, but the project can’t compile because “audiodecoder.h” can’t be found. I have no idea where to locate this file :confused:

could this be related to OF versions?

thanks in advance for your help!

Hi, ofxTimeline is kinda outdated. I had the same problem the other day and fixed it.
audiodecoder.h is part of the libaudiodecoder that should be included in ofxAudioDecoder but there are some issues with the project generator and it is not adding all the includes correctly. try adding ofxAudioDecoder to your project. that should work. Which os and ide are you using?

2 Likes

hi roy, thanks for your answer!

I saw on the github page that ofxTimeline hasn’t been updated for a while, but from what i’ve seen it seems to be the only easy way to deal with timelines in OF. Would you have any other suggestion?

I’ve also tried to include ofxAudioDecoder after generating the project but that doesn’t solve the problem, I’ll try to generate a new project tomorrow and include ofxAudioDecoder in the first place.

Concerning the IDE, I’m using Visual Studio Community 2015 with the OF Plugin.

I’ve used it with pre 0.9.0 releases. Since I wasn’t using any of the audio or video portions, I just commented it out and didn’t have any issues.

Its an awesome add-on that I wish was kept up. Still does what I need it to do very well though.

yeah whats giving problems is the audio section of it. make sure that TIMELINE_AUDIO_INCLUDED is undefined and just remove from your project all the files from the libs folder of ofxTimeline. also remove ofxTLAudioTrack.h and ofxTLAudioTrack.cpp thats all. And btw, you wont have the audio features in ofxTimeline.
best

thanks for your answers guys!

okay, i’m not realy sure what you mean by making sure TIMELINE_AUDIO_INCLUDED is undefined. Should I write

#undef TIMELINE_AUDIO_INCLUDED

instead of

#ifdef TIMELINE_AUDIO_INCLUDED
#include "ofxTLAudioTrack.h"
#endif ?

C++ noob here …

thanks !

No, just search all your project for TIMELINE_AUDIO_INCLUDED and just make sure that it isn’t defined like #define TIMELINE_AUDIO_INCLUDED. xcode and vs have a find in all files options. it should be fast and easy. I think that it is not defined by default.

Hi Everyone !

We found the same problem some weeks ago and thanks to @jamesacres we could solve it …
James was able to remake the XCodeProj to make ofxTimeline to work (including ofxTLAudioTrack, so the audio too).

I share the link where we have the test app with sound working …
https://drive.google.com/file/d/0B9uvV2Mn11oELVZTNzBSRC01Smc/view?usp=sharing

I’ll try to explain what changes did @jamesacres to make it work .

We made that as we where trying to build Duration (the app that uses ofxTimeline) with OF 09 … That we already did too (in case someone is interested on building Duration for OF 09).

We love ofxTimeline and Duration, and we would love to see it updated to the newest OF releases …
Is anybody else interested on continuing ofxTimeline or Duration projects ? To maintain them updated and maybe keep upgrading it ? I guess James George @obviousjim has no time to maitain it …

We would be happy to collaborate …

2 Likes

Hey! I compiled with success and ran most of the examples on 0.9.3 in OSX, audio and video included. :slightly_smiling:
That’s the process I followed:

1-
In order to make the audio run I had to modify the up-to-date ‘ofxAudioDecoder’ like this: https://github.com/kylemcdonald/ofxAudioDecoder/issues/5
changing to #ifdef TARGET_OF_IOS instead of #ifdef TARGET_OF_IPHONE:

2-
Rename all the ‘testApp’ to ‘ofApp’ (filenames and content of them), and update each project with ProjectGenerator. Sometimes I had to re-add the ‘ofxAudioDecoder’ addon dragging it manually because some lib errors…

3-
On the project tab / building settings, you have to add the lines ‘TIMELINE_AUDIO_INCLUDED=1’ & ‘TIMELINE_VIDEO_INCLUDED=1’ (if used) on ‘Preprocessor Macros’:

4-
On the ‘/src/ofApp.h’ of your project file, you have to add the lines:
#include “ofxTLAudioTrack.h”
#include “ofxTLVideoTrack.h”

2 Likes

Thanks everybody for the help.

If anyone needs it, in my fork of ofxTimeline I have the following examples ready to compile with OF 0.9.3, Xcode 7.3, and OSX 10.11:
allTracks - cameraTrack - videoRenderer - emtpyTrackTemplate - audiowaveform - emptyExample
link:

(!)ofxAudioDecoder: I removed the following files from ofxAudioDecoder dir, because they are for Windows os, and gave me header related errors:
libs/audiodecoder/include/audiodecodermediafoundation.h
libs/audiodecoder/src/audiodecodermediafoundation.cpp

3 Likes

Hi @lzmmrman and everyone else! Thanks for your work and comments on this.

Been trying to build all the examples from your fork with Xcode and here are the results:

Working (building and running):

  • example-allTracks
  • example-audiowaveform
  • example-cameraTrack
  • example-emptyExample
  • example-emptyTrackTemplate

Not working:

  • example-curvesAndColors
  • example-lfo
  • example-multiTimeline
  • example-videoRenderer

I haven’t had time to look at what the exact problems are, but all of them share build (not link) errors related to ofxMSATimer, ofxXml, and ofxAudioDecoder.

Also, ofxTimelineLib requires 10.8 as Base SDK. Is it mandatory? Tried builds using 10.11 with no luck because of (again) ofxAudioDecoder and ofConstants.h including #include <unordered_map>. This include issue is kind of weird, since it works for other projects with no problems at all.

My specs:

  • El Capitan 10.11.4 (15E65)
  • Xcode 7.3.1 (7D1014)
  • OF 0.9.3
  • Only the latest OSX SDK installed (10.11)

I’ll try to fix it locally and if I’m sure it doesn’t break anything I’m sending a pull request to your repository but, in the meantime, any help on these? Thanks!

In my for of ofxTimeline theres a file “ofv09_osx_compilation_issues.md” where I listed the solutions for the different issues that appears when compiling of 0.9.0.
As I mentioned in my last post not all example projects where fixed to compile, but you cant take the empty example as a reference or any other to make the other ones run.

Oh, I missed the ofv09_osx_compilation_issues.md file. I’ll try those solutions. Thanks a lot.

Hello, anyone knows if the addon can run on Visual Studio / Windows?
I am getting some errors related to ofxTextInputField like:

> Error 'ofxTextInputField::isEditing': cannot access protected member declared in class 'ofxTextInputField' example-multiTimeline C:\Users\manu\Documents\of_v0.9.3_vs_release\addons\ofxTimeline\src\ofxTLFlags.cpp 104

I tried to run the ofxTextInputField addon itself, with his own example but doesn’t compiles:

Error ‘getCocoaWindow’: is not a member of ‘ofAppBaseWindow’ example-textInput C:\Users\manu\Documents\of_v0.9.3_vs_release\addons\ofxTextInputField\src\ofxTextInputField.cpp 341
Error ‘getCocoaWindow’: is not a member of ‘ofAppBaseWindow’ example-textInput C:\Users\manu\Documents\of_v0.9.3_vs_release\addons\ofxTextInputField\src\ofxTextInputField.cpp 346

Hi @moebiussurfing !
Try replacing each “isEditing” with “getIsEditing()”. It worked for me! :slight_smile:

2 Likes

Hi, can anyone help me with an ofxTimeline build error?

I just found this post, but I had already created a seperate post for my issue earlier today.

Here’s a link to the post detailing my build issue:
Need help with ofxTimeline / openFrameworks 9 build error (Xcode / OSX Sierra).

If you can help, please comment on that post.

Thank you!
-Chris

1 Like