Can't run openframeworks in iOS with Xcode 8

Hi everybody,

I’m in the middle of a comercial project with OF and iOS. I’m able to build the code but I can’t run it on the device. I got the following errors.

Code signing is required for product type ‘Application’ in SDK ‘iOS 10.0’

Anyone knows how to fix it? would appreciate any help.
best,
J

Hi!

Was this working fine before you upgraded to Xcode 8?
Did you check that you had a valid profile in your Xcode project settings?

Googling this error I see the following:

Maybe we need to change the iOS Xcode project to have automatically manage signing enabled?

I found a workaround, posted on github issues:

https://github.com/openframeworks/openFrameworks/issues/5274

1 Like