Can't run examples in Xcode, signing issue with libfmodex.dylib?

#1

Hey everybody,

Back in OF land after a longtime away, looking forward to getting back in, but I’m having trouble getting the latest release working in Xcode.

I get the following error whenever I try to run an example or a new project:

It does actually build the example and I can run the executable in the bin folder, but obviously it’ll be hard to debug that way. At first I thought it was an issue that I hadn’t signed in with my dev account, but I got the same error when I did:

Does anyone know how to fix this in Xcode? I saw some posts about fixing signing libfmodex.dylib for release, but I’m still just trying to get things to run in Xcode.

Thanks in advance!
Matt


just putting this part below in text to help with search ability for future devs is they run into a similar issue:
/Applications/Developer/of_v0.10.1_osx_release/examples/video/asciiVideoExample/bin/asciiVideoExampleDebug.app: code object is not signed at all

In subcomponent: /Applications/Developer/of_v0.10.1_osx_release/examples/video/asciiVideoExample/bin/asciiVideoExampleDebug.app/Contents/Frameworks/libfmodex.dylib

#2

are you using Xcode 11+ ? can you try the nightly build of OF from the downloads page?

1 Like
#3

Nightly build of_v20190924_osx_release did the trick for me with the following version of Xcode 11+
39%20AM

Thanks for the quick response @zach and for the timely post @madparker :smile:

1 Like
#4

I was running Xcode 11+

Nightly build worked for me, too! Thanks @zach for the quick reply!

Code Sign Error
Can't build, getting "build failed" with any example "code sign error"
#5

Anyone know what the fix was? I tried to look in the commit history to see what was fixed in the nightly build but could not find the relevant commit.

#6

the change was done to a compiled external dependency and as such doesn’t appear in the main OF repo. If you are using OF from github you might need to re-run download_libraries.sh in order to get the latest external dependencies, including this fix

#7

The nightly fixed it for me, too. maxOS 10.15, Xcode 11.1.

#8

I am getting this error running Xcode 11.2:

I’m not sure if this is the correct thing to do but it solves the problem. Under Build Settings on the application target search for identity.

Remove by clicking “other” from the drop-down and clearing it: