Can't play video on Ubuntu 16.04, GStreamer error

#1

hi friends,
I am having problems playing videos with of 0.9.8 on Ubuntu 16.04 LTS

The same program works like a charm in an Ubuntu 17.04 VM inside OSX. I followed all the instructions for setting up OF (including the install_codecs script) and everything seems to be running fine, but trying to play a video results in the following:

HOST_OS=Linux
checking pkg-config libraries:   cairo zlib gstreamer-app-1.0 gstreamer-1.0 gstreamer-video-1.0 gstreamer-base-1.0 libudev freetype2 fontconfig sndfile openal openssl gl glu glew gtk+-3.0 libmpg123 
[ error ] ofGstUtils: gstHandleMessage(): embedded video playback halted for plugin, module uridecodebin0  reported: Your GStreamer installation is missing a plug-in.[ error ] ofGstUtils: startPipeline(): unable to pause pipeline after 5s

[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded
[ error ] ofPixels: format doesn't support channels
[warning] ofGstUtils: getDurationNanos(): couldn't query time duration

and so on until the application is stopped. This comes from the videoplayer example, so it is not related to my code.

The hardware is a Kodlix AP42 mini PC (also known as Beelink) with an Intel Apollo lake processor, if that matters.

thank you for helping
Davide

Is OF98 compatible with Ubuntu 17.04?
#2

have you run the install_codecs.sh script? also if the video plays back in the totem video player it should play fine in OF

#3

Yes, I run the install_codecs.sh script. As far as I know it did everything it should, without complaining.

Now I can’t test the totem video player but I’ll do it tomorrow and I’ll let you know what happens.

#4

Totem complained about some missing plugins (codec gstremaer1.0-libav, gstreamer1.0-plugins-bad-faad, gstreamer1.0-plugins-bad-videoparsers) and offered to install them.

After that video is working in OF applications too. Problem solved, someway, but it would be nice to understand why it didn’t work out of the box… Ubuntu was a fresh installation without any other software.

#5

I had this issue too. Ubuntu 18.04 fresh install with nightly build OF1.0.1 ( of_v20191015_linux64gcc6_release ) and finally worked after do a manually uninstall and reinstall Gstreamer1.0 with this:

sudo apt-get install --reinstall gstreamer1.0-alsa gstreamer1.0-libav gstreamer1.0-plugins-bad gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly gstreamer1.0-pulseaudio libgstreamer-plugins-bad1.0-0 libgstreamer-plugins-base1.0-0 libgstreamer-plugins-good1.0-0 libgstreamer1.0-0

From here