Cant play audio files on Raspberry pi- fast help in the middle of a project [solved- ish]

There seems to be an issue with the sound player on raspberry pi. I am using the latest nightly and Jessie. I ran all the apt update/upgrade commands as well.

cat /proc/version
Linux version 4.9.28-v7+ (dc4@dc4-XPS13-9333) (gcc version 4.9.3 (crosstool-NG crosstool-ng-1.22.0-88-g8460611) ) #998 SMP Mon May 15 16:55:39 BST 2017

When I try to load any sound file (even just trying to run the soundPlayer Example I get this error:

AL lib: (WW) alc_initconfig: Failed to initialize backend "pulse"
[ error ] ofOpenALSoundPlayer: sfReadFile(): couldn't read ""data/sounds/1085.mp3""
Floating point exception
/home/pi/openFrameworks/libs/openFrameworksCompiled/project/makefileCommon/compile.project.mk:190: recipe for target 'run' failed
make: *** [run] Error 136

It would be great if anyone can shed some light on this, I am a bit stuck without audio playback. I cannot use video as I need to run 6 files at once.

I have tried wav and mp3, and no change.

Cheers

Ok, wav files do work but mp3 is broken.

@fresla - I can’t seem to run wav files either. After updating my raspberry pi using sudo apt-get update, when I ran my ofSoundPlayer examples, I see this error when I load a file.

ofSoundPlayer player;
player.load(“myaudio.wav”);

Error:
connect(2) call to /tmp/jack-1000/default/jack_0 failed (err=No such file or directory)

It seems like a firmware update has broken this. Because it was totally working last time I had this. Anybody have any ideas on how to get around this?