Can't install on fedora

Hi everybody. I’m new on open frameworks. However I’ve some solid Java background and have some skills with linux. I’m on fedora (have some computer with F8 and another with F10 but here I’m on the F8 one).

I tried to install OpenFrameworks 0.6 (the Fat version) but didn’t succeed.

First, at the source level, there wasn’t any codeblocks-*.tar.gz. In fact, the make dist process created some archive, but it was a tar.bz2.
Then I had to transfer the tar.bz2 content into some tar.gz to get this part working. Now my install_codeblocks_svn.sh file looks like :

  
## download codeblocks from svn compile generate rpm and install  
  
yum install subversion intltool wxGTK-devel libjpeg-devel libtiff-devel  
su -c'yum groupinstall "Development Tools"'  
  
cd  
mkdir rpm  
echo "%_topdir $HOME/rpm" >> .rpmmacros  
mkdir /tmp/$USER  
mkdir /tmp/$USER/rpm  
echo "%_tmppath /tmp/$USER/rpm" >> .rpmmacros  
cd rpm  
mkdir SPECS SOURCES BUILD RPMS SRPMS  
RPM_TOPDIR=`rpm --eval %{_topdir}`  
  
svn checkout svn://svn.berlios.de/codeblocks/trunk codeblocks  
cd codeblocks  
./bootstrap  
./configure --enable-contrib  
make dist  
  
### XION NEW ###  
mkdir tmp  
FILE=$(ls codeblocks-*)  
FNAME=${FILE%%.tar*}  
cd tmp/  
tar xvjf ../codeblocks-*.tar.bz2  
tar cvzf $FNAME.tar.gz *  
cd ..  
mv tmp/$FNAME.tar.gz .  
rm -rf tmp  
### XION END ###  
  
mv codeblocks-*.tar.gz $RPM_TOPDIR/SOURCES  
rpmbuild -bs codeblocks.spec  
cd ~/rpm/SRPMS  
rpmbuild --rebuild codeblocks-*.src.rpm  
cd ~/rpm/RPMS  
su -c"rpm -Uvh codeblocks-*.i386.rpm"  
  

Now the installation go further, but it still fails ! :smiley:
Since I have codeblocks installed from yum (v. 8.02, but there are some information about it not being the good version to use), I tried to compile some example, but there are many problems. I didn’t succeed. No project works… :?

And there is some problem whenever I open a project. It tells me :

LibFinder error :

Found following issue with libraries :
Didn’t find configuration for libraries :
* gstreamer-video-0.10

For example, if I try to run the xmlSettingExample, then I get :

||=== xmlSettingsExample, Debug ===|
/home/xion/Documents/dev/of_preRelease_v0.06_linux_cb_FAT/libs/openFrameworks/video/ofVideoPlayer.cpp||In constructor ‘ofVideoPlayer::ofVideoPlayer()’:|
/home/xion/Documents/dev/of_preRelease_v0.06_linux_cb_FAT/libs/openFrameworks/video/ofVideoPlayer.cpp|234|erreur: ‘gst_plugin_register_static’ was not declared in this scope|
||=== Build finished: 1 errors, 0 warnings ===|

What should I do ?

Hi

not completely sure, but the gstreamer-video-0.10 module is kind of new it seems it doesn’t exists in fedora 8 gstreamer. i only tried with fedora 10.

apart from that codeblocks 8.02 should work ok, only you will need to run apps from the clickToLunchApp.sh script in the bin directory once your app compiles.

Is there any rpm for gstreamer-video or is it included in the core gstreamer rpm ?

On rpm-fusion, I can’t find any gstreamer-video rpm, even for F10 :
neither on stable : http://download1.rpmfusion.org/free/fed-…-group.html
nor on updates : http://download1.rpmfusion.org/free/fed-…-group.html

In all cases, I’ll try installing it on my F10. I know F8 is no more supported (End of Life from december 2008), but it sounds strange…

no, thre’s no gstreamer-video, it’s part of gstreamer or gstreamer-base.

If you want to give it a try perhaps you can update gstreamer to a newer version from rpm-fusion or similar.

Hi again ! :smiley:
I tried to use some example : imageLoaderExample, it compiles and I can run it from shell with the script for it, but on codeblocks, I get some build errors. In the build log, there are now some info about it working correctly. However there’s still some errors in build. It’s hard to understand how it can then work even if there are still errors !

||=== imageLoaderExample, Debug ===|
/usr/include/ffmpeg/libavcodec/avcodec.h|2388|attention : ‘ImgReSampleContext’ is deprecated (declared at /usr/include/ffmpeg/libavcodec/avcodec.h:2382)|
/usr/include/ffmpeg/libavcodec/avcodec.h|2398|attention : ‘ImgReSampleContext’ is deprecated (declared at /usr/include/ffmpeg/libavcodec/avcodec.h:2382)|
/home/xion/Documents/dev/of_preRelease_v0.06_linux_cb_FAT/libs/openFrameworks/video/ofVideoPlayer.cpp||In constructor ‘ofVideoPlayer::ofVideoPlayer()’:|
/home/xion/Documents/dev/of_preRelease_v0.06_linux_cb_FAT/libs/openFrameworks/video/ofVideoPlayer.cpp|234|attention : deprecated conversion from string constant to ‘gchar*’|
||=== Build finished: 3 errors, 0 warnings ===|

These errors are only deprecated things. Is there any way to tell codeblock not to hurry so much. It might tell me there are “warnings” for deprecated things, but I don’t want it to complain with “errors” as those “errors” don’t break the binary for real. :?

This is because codeblocks only understand warnings when they are in us english, i suppose attention is for warnings in uk english?

you can change that by adding a var to the environment config:

settings > environment settings > environment variables

and there press add and add a new var with name LC_ALL and value C

that way gcc will output messages in us english and that errors will turn to warnings.

Thanks a lot ! :wink: