Can't install Kinect drivers

Using depth cameras like Kinect seems to be an important feature of openFrameworks, so I’m trying to get it working on my Windows 10 machine. It’s a Kinect XBOX360 Model 1414, but when running the kinectExample, I get “no available devices found”.

Now, I’ve tried downloading zadig as per the README, but the only device that shows up is Xbox NUI Motor and if I try to install libusbK(v3.1.0.0) I get “Installation Failed”. (I’ve read that the Xbox NUI Motor needs to have its driver installed first before you can access the other parts of the Kinect)

Furthermore, I can’t get any drivers to install for Xbox NUI Motor from the Device Driver either.

The LED at the usb-power connection is green, but nothing on the Kinect itself is lit up.

I’ve tried reinstalling the Kinect SDK 1.8 (this worked for me in the past when I wanted to use touchlesstouch) and even the developer tools, but it doesn’t help.

I realize this is more of a Kinect issue than an oF issue, but I’ve Googled quite a bit and am unsure of where to ask… like, there’s a kinect subreddit, but it’s kind of dead…

Hey @s_e_p

I think you need libusbk 3.0.6.0. Newer versions have issues.

Try using the zadig recommended in the ofxKinect ReadMe ( 2.0.1 ):

Make sure you also check ‘list all devices’ in the Zadig menu and that the Kinect is powered.
If it is not powered you will only get the Motor showing up.

Hope that helps!
Theo

Thanks, theo, I’ll look into that older version.

If the Kinect is powered, should something be lit up on the camera itself? Like I said, it’s plugged in, and the cable connector is lit up, but not the camera body itself.

I’ve found that on a PC that doesn’t have drivers installed I don’t see any LED on the camera body.

For a PC with the libusbk drivers the led flashes yellow when first plugged in and red after it has been run and shutdown successfully.

Hope that helps!
Theo

1 Like

@theo Got it working! I followed the advice on this page, which didn’t work at first, but then I took the advice in the comments about rebooting after the uninstall. So I…

  1. Unplugged the Kinect from the USB
  2. Uninstalled SDK 1.8
  3. Rebooted
  4. Reinstalled SDK 1.8
  5. Rebooted (for good measure)
  6. Replugged the Kinect. Now the Kinect devices show up in Device Manager & zadig
  7. Used the zadig version you sent me to set all the X-Box/Kinect devices to libusk 3.0.6.0

and now the kinectExample works! Thank you! (That’s so wack though xD )