Can't build examples..undeclared identifier GL_UNSIGNED_INT_OES

of_0071_iOS_release (just downloaded)

OSX 10.6.8

Xcode 4.0.1

IOS SDK 4.3

emptyExample project (although i have checked others)

Used OpenFrameworks for a while but not for iPad/iPhone/IOS. Just trying to build any of the examples to get started. Build is failing with

  
 'GL_UNSIGNED_INT_OES' was not declared in this scope  

in ofFbo.cpp. I guess something isn’t linking the GL ES correctly?

I sort of hoped the examples would just build as is. I have tried using Xcode to just build a native iPad (simulator) app and that worked fine on both iPad and iPhone so i guess that the libraries are there, just not getting linked. I tried doing a clean also.

Any help much appreciated.

nik

on further looking i don’t see GL_UNSIGNED_INT_OES defined in core frameworks>OpenGLES.framework/headers/ES1 or ES2 glext.h

I quickly swapped (totally incorrectly of course) the define to some other, and the build worked. I guess it must be some bad matching of framework version or something on my part. Anyhow at least i have the thing building and running in the simulator now.

That should be fixed in this commit: https://github.com/openframeworks/openFrameworks/pull/1276 so if you’re still running into errors on the newest release, you might make a note of it there. It’s only defined in iOS5.x so that could be one way it’s causing trouble for you?

Just hit the same error on 072 (IOS build) trying to build for IOS 5 SDK.