Cannot make this work :(

following the guide here:

https://openframeworks.cc/setup/linux-install/

installed everything ok but when I try to run projectGenerator:

isma@isma-MS-7C37:~$ sudo projectGenerator --ofPath

[ error ] ofPath seems wrong… not a directory

however, my environmental variable is set like so:

PG_OF_PATH="/home/isma/Documents/of_v0.11.0_linux64gcc6_release"

i’ve even tried:
isma@isma-MS-7C37:~$ sudo projectGenerator --ofPath home/isma/Documents/of_v0.11.0_linux64gcc6_release

[ error ] ofPath seems wrong… not a directory
isma@isma-MS-7C37:~$ sudo projectGenerator --ofPath “home/isma/Documents/of_v0.11.0_linux64gcc6_release”

[ error ] ofPath seems wrong… not a directory

out of ideas here.

Hi,
I’m using the commandline projectGenerator on Linux (Raspberry Pi) with a relative path (probably I’ve also ran into issues with absolute paths?)
Anyway, when I’m in /home/pi/of_v0.11.0_linuxarmv6l_release/apps/myApps
I use the relative path like this
projectGenerator -o"../.." projectName
(First time I run it I get an rerror:

[ error ] ofFile: copyTo(): source file /home/pi/of_v0.11.0_linuxarmv6l_release/apps/../scripts/templates/linuxarmv7l/qtcreator.qbs does not exist
[ error ] QtCreatorProject: error copying qbs template from /home/pi/of_v0.11.0_linuxarmv6l_release/apps/../scripts/templates/linuxarmv7l/qtcreator.qbs to /home/pi/of_v0.11.0_linuxarmv6l_release/apps/myApps/projectName/projectName.qbs

)
Ran it again, and now I have a project that I compiles with make.
Hope this does the/a trick
Oh, and by the way, a better topic-name might be helpful :wink:

no sure if it’s the source of your problem, but avoid sudo when invoking projectGenerator. It’s not needed, and probably will cause troubles
So, in your case, just

projectGenerator --ofPath “home/isma/Documents/of_v0.11.0_linux64gcc6_release”

HTH

Also I think home/isma/.... should be /home/isma/....

Agree on the use of sudo too - better to avoid.

Hope that helps!
Theo