Cannot build Openframeworks on Xcode!?

I am new to this and I am trying to build an emptyExample.
I keep getting build failed with multiple error messages. (attached)
I checked that the scheme is not set to openframeworks.
How do I resolve this ? :frowning:

Hi,

Welcome to the forum!

Is this OF 0.11.2 OSX / macOS release?
Also which version of Xcode and macOS are you on?

It might be that something changed recently with latest Xcode.

You could try removing the highlighted text from libs/openFrameworks/utils/ofConstants.h:

the OF is macOS release/
The version of my macOS is macOS Big Sur version 11.2.3

I tried removing the text you highlighted, still cannot build it :frowning:

Hmm .
I just tried the 0.11.2 release:

On Xcode 12.3 and Big Sur 11.2.3 and the emptyExample worked fine for me.

Which Xcode version are you using?

Thanks!
Theo

Mine is Xcode 12.5 beta 3!

so I tried redownloading Xcode with the version you used: 12.3 (not beta)
and then try building the empty proj again and still failed.
The error messages are as shown:

Hi,

That error is familiar at least :slight_smile:

It is an issue with iCloud Drive and Code signing
See the steps here: Error: Command /usr/bin/codesign failed with exit code 1 · Issue #6705 · openframeworks/openFrameworks · GitHub

One other general tip:

  • Try to avoid spaces in your project folder names. I don’t think that is the issue here but it can cause some issues when using absolute paths.

Hope you get it all working!
Theo

Wow thank you!
That solved the problem.
Although I don’t use iCloud.
I realised if I move the folder to Onedrive, I need to change the setting to keep as Xcode version to make it work.