Cannot build any project/example on MacOS

I am coming back to openframeworks after not using for a while and I have problems to compile any empty project or any samples included. I tried my previous openframeworks 11.0 I had and also the latest 11.2 but I always keep getting error:

/Users/patryk/Developer/tools/libs/openFrameworks/sound/ofFmodSoundPlayer.h:11:10: ‘fmod.h’ file not found

I’m using intel macbook and I’m on Big Sur 11.6 and Xcode 13.2.1.
I noticed that on each project have to check box “Do not show a diagnostic issue about build system deprication” in Xcode → File → Project Settings

I think there is something going wrong with path in error its tells:
/Users/patryk/Developer/tools/libs/openFrameworks/sound/

but my openframeworks is in:

/Users/patryk/Developer/tools/of_v0.11.2_osx_release

I created in empty project with project generator and made sure path is correct but still the same error.

can you try cleaning the project? Also can you try enabling the new build system? under project settings, new build system

I’d also recommend downloading a brand new OF and trying any of the examples that it ships with to see if those compile.

Unfortunately nothing helped: I deleted previous version and downloaded again of_v0.11.2_osx_release tried /apps/myApps/emptyExample as well new empty project generated by projectGenerator (/app/myApps/mySketch) and in both cases cannot compile project. For legacy build I guess the same error as above and for new build I get:

Command PhaseScriptExecution failed with a nonzero exit code

** BUILD FAILED **


The following build commands failed:
	CompileC /Users/patryk/Developer/tools/of_v0.11.2_osx_release/libs/openFrameworksCompiled/lib/osx/build/debug/openFrameworks.build/Objects-normal/x86_64/ofSoundPlayer.o /Users/patryk/Developer/tools/of_v0.11.2_osx_release/libs/openFrameworks/sound/ofSoundPlayer.cpp normal x86_64 c++ com.apple.compilers.llvm.clang.1_0.compiler (in target 'openFrameworks' from project 'openFrameworksLib')

I also get some warning related for iphone simulator for whatever reason even though I’m using osx versions which is weird:


Warning Group
Traditional headermap style is no longer supported; please migrate to using separate headermaps and set 'ALWAYS_SEARCH_USER_PATHS' to NO.
/Users/patryk/Developer/tools/of_v0.11.2_osx_release/apps/myApps/mySketch/mySketch.xcodeproj User-supplied CFBundleIdentifier value 'cc.openFrameworks.mySketchDebug' in the Info.plist must be the same as the PRODUCT_BUNDLE_IDENTIFIER build setting value ''.
Building targets in manual order is deprecated - check "Parallelize build for command-line builds" in the project editor, or set DISABLE_MANUAL_TARGET_ORDER_BUILD_WARNING in any of the targets in the current build to suppress this warning
Skipping duplicate build file in Compile Sources build phase: /Users/patryk/Developer/tools/of_v0.11.2_osx_release/libs/openFrameworks/app/ofBaseApp.cpp (in target 'openFrameworks' from project 'openFrameworksLib')
Traditional headermap style is no longer supported; please migrate to using separate headermaps and set 'ALWAYS_SEARCH_USER_PATHS' to NO. (in target 'openFrameworks' from project 'openFrameworksLib')
/Users/patryk/Developer/tools/libs/openFrameworks/utils/ofConstants.h:94:67: 'TARGET_OS_IPHONE_SIMULATOR' is not defined, evaluates to 0 [-Wundef-prefix=TARGET_OS_]

even deleting all DerivedData didn’t help, so frustrating :frowning:

I also found out for some reason the following folder is empty:

/Volumes/macos/Users/patryk/Developer/libraries/openframeworks/of_v0.11.2_osx_release/libs/fmod

are you using iCloud Drive or something like dropbox with that folder ? I’ve seen sometimes issues where when you use a tool that is designed to save space on your hard drive, it may move files around or even delete them…

I haven’t seen the exact issue you are mentioning, but I am generally suspicious – some posts that aren’t your exact problem but mention iCloud Drive as a reason

1 Like

don’t use any iCloud for data storage and my dropbox is in completely different folder. But thanks for the clue! I’m using Forklift.app as my file manager and it seems probably that was the issue. When unzipped using build in macos Finder the /fmod folder is not empty. Just my Forklift.app always for some reason when unzip /fmod was empty - to make it even more weird when in Forklift I right click and ‘show archive content’ it’s showing correctly.

Anyway I tested again oF 11.2 after unzipping with finder and sample compile and works.
Thanks a lot for the clue!

2 Likes

ah that’s great to hear – thanks for following up! forklift must have something against fmod :slight_smile:

I reported the issue to Forklift and they reproduced it so it seems that’s definitely something wrong on their side - FWIW in case someone has similar issue.