Camera with firewire not recognized in OSX 10.14 and USB-C

#1

Hi.

Since I upgraded my computer to a new Macbook with USB-C, I’m dealing with a problem: my cameras with firewire are not being recognized by openFrameworks.

In particular, I found that the listDevices() function at ofAVFoundationGrabber.mm is not returning more that one camera, the one that it gets is the builtin one but no firewire at all.

NSArray * devices = [AVCaptureDevice devicesWithMediaType:AVMediaTypeVideo];

I tried this with Processing and it worked without a problem, so it happened with iMovie, so the camera is working.

Does anyone have a clue for this?

#2

I thought I had found the solution…

NSArray *devices = [[AVCaptureDevice devicesWithMediaType:AVMediaTypeVideo] arrayByAddingObjectsFromArray:[AVCaptureDevice devicesWithMediaType:AVMediaTypeMuxed]];

This is the code that should be placed in order to get the list of devices (ofAVFoundationGrabber.mm line 247 and line 42).

But… the format (AVCaptureDeviceFormat) fills as an empty object so I can’t set the proper dimensions to the capture.

It gets an image but is on the wrong dimensions. It returns an image of 702 px width, so the lines are displaced.

==== EDIT

I tried to force the capture size to the one that I setted up with the initGrabber.

                size_t widthIn  = grabberPtr->getWidth(); //CVPixelBufferGetWidth(imageBuffer);
                size_t heightIn	= grabberPtr->getHeight(); //CVPixelBufferGetHeight(imageBuffer);

This gives me an image that is -amost- ok. It is somehow shifted.

CVPixelBufferGetWidth(imageBuffer)

is returning a wrong number.