Camera Problems ( PS3 Eye Grabber)


#1

Hi,
Im working on an optical flow code, and am using the Playstation eye camera ( link: camera
This camera requires a particular add-on, which is called “ofxPS3EyeGrabber”.
Link for add-on : add-on
I tested out the add-on with my camera, and I have encountered a few problems.
This is when I am testing my code as well as the examples given in the add-on.
Sometimes the video doesn’t display, it gives a black screen, other times it displays a green filter on the video feed, sometimes a blue filter, and other times the pixels of the feed are squashed to one point ( usually on the left side of the screen.
Once in a blue moon it gives the right webcam feed ( which is my normal face).
I was wondering if the error lies with the camera, or with me ( as in the code,) or the add-on?

Any advice would be helpful :slight_smile:

( example of the green screen that comes up, with the optical flow code)


#2

Hi there, a few questions:

  1. What version of openFrameworks are you using?
  2. What version of ofxPS3EyeGrabber are you using?
  3. I’ve seen results like this on occasion when the USB connection is bad. Have you tried moving the camera to a different port?

#3

Hi,
here are the answers :
1: The version I am using is the 0.98 release, the latest one
2: and same with the add-on, I just downloaded it.
3: I have tried, and it does make the feed appear more than once, but the green screen comes often.


#4


#5

The current master branch has only been tested with the master branch of openFrameworks. Can you try the stable version of the addon?


#6

hmm, Ill try that. thanks!


#7

Hi, did you find a solution or reason for this?

I’m having the same problem with openFrameworks master branch from github and the ofxPS3EyeGrabber master branch.

The cameras are working as expected with 0.9.8 and ofxPS3EyeGrabber stable.

The reason I switched over to the master branch was due to an error passing frames from the PS3Eye to ofxCv::imitate .
//[ error ] ofPixels: format doesn’t support channels

I’m on OSX 10.12.1


#8

Hi,
No the problem is the same. I think the camera is faulty. I tried it with the stable and master branch. The error was the same. It is such a weird error because the camera displays a good image every once in a while. I am working with a 0.9.8 version, but with the master branch. It works better.