Building poco - build/poco folder where? how?

Hi there.

Absolute beginner here.
After hours trying to install all dependencies without getting an error regarding poco and gcc5, I’m having this one:

chown: cannot access ‘build/poco’: No such file or directory

I would like to ask you:
What am I missing?
Where can I get this folder build/poco and where it should live?

I guess this is an easy one. But I couldn’t find the answer anywhere.

thank you in advance

best regards,
Gil

What system are you on? Usually you can compile poco with the install dependencies script.

Hi

I’m in Linux Ubuntu

thanks

Check this page: http://openframeworks.cc/setup/linux-install/

I think this should compile POCO:

cd OF/scripts/linux/ubuntu sudo ./install_dependencies.sh

Hi Underdoeg.

First off all, thank you for your attention.

Maybe is time to tell the whole story, including the progress I’ve made so
far.

I have already read the page you pointed me. But at the end of the sudo
./install_dependencies.sh I got a complain, saying that POCO should be
rebuild because I’m using gcc5… “please press any key”… and then I got
an ERROR about not finding apothecary/something (I can’t remember exactly).

I wish it was some reference and explanation about apothecary. It took me a
while to figure out where it should be and how to use it. I built finally
POCO trough it (in the meanwhile got an error about not having curl inside
a script), and then, again I ran sudo ./install_dependencies.sh which
rebuild POCO.

Of course I ran the other scripts from the Setup / Linux Install page.

I was then optimistic, but as I tryied to run an example (graphicsExample)
in QT Creator (3.6) I had lots of Issues (40!), most of them regarding
something about POCO.

Here are the two first of them:

1st:

In Funktion `ofLaunchBrowser(std::__cxx11::basic_string<char,
std::char_traits, std::allocator > const&, bool)’:

File not found:
/home/gil/of_v0.9.3_linux64_release/libs/openFrameworksCompiled/lib/linux64/libopenFrameworksDebug.a(ofUtils.o)

libopenFrameworksDebug.a(ofUtils.o)

2nd:
Nicht definierter Verweis auf
`Poco::URI::URI(std::__cxx11::basic_string<char, std::char_traits,
std::allocator > const&)’

/home/gil/of_v0.9.3_linux64_release/libs/openFrameworks/utils/ofUtils.cpp:856:

Well here is where I am. I will take a closer look at ofUtils, goggle it…
still trying to run my first example and finally start to learn oF.

thanks again underdoeg

best regards,
Gil

underdoeg forum@openframeworks.cc schrieb am Mo., 4. Juli 2016 um
10:33 Uhr:

Ok, the first error you can ignore, since it only tells you that the openframeworks library wasn’t found. It could not be built since you have issues with poco…

Do you have several .a files within libs/poco/lib/linux64?

Hi.

I have 11 of them:

libPocoCrypto.a
libPocoData.a
libPocoDataSQLite.a
libPocoFoundation.a
libPocoJSON.a
libPocoMongoDB.a
libPocoNet.a
libPocoNetSSL.a
libPocoUtil.a
libPocoXML.a
libPocoZip.a

That is good. This means poco is compiled and should be available. Does it mention any of these files within the error messages?

No. Actually not. It seams (I’m just guessing) everything starts to go wrong in this part of ofUtils.cpp

void ofLaunchBrowser(const string& url, bool uriEncodeQuery){
Poco::URI uri;
try {
uri = Poco::URI(url);
} catch(const std::exception & exc) {
ofLogError(“ofUtils”) << "ofLaunchBrowser(): malformed url “” << url << “”: " << exc.what();
return;
} …

In the compile output there are some more informations:

p, li { white-space: pre-wrap; }

/home/gil/of_v0.9.3_linux64_release/libs/openFrameworksCompiled/lib/linux64/libopenFrameworksDebug.a(ofUtils.o): In Funktion `ofLaunchBrowser(std::__cxx11::basic_string<char, std::char_traits, std::allocator > const&, bool)’:

/home/gil/of_v0.9.3_linux64_release/libs/openFrameworks/utils/ofUtils.cpp:856: Nicht definierter Verweis auf `Poco::URI::URI(std::__cxx11::basic_string<char, std::char_traits, std::allocator > const&)’

and so on and so far until:

Process failed with exit code 1.
The following products could not be built for configuration qtc_Desktop_b78dca7a-debug:
graphicsExample
Error while building/deploying project graphicsExample (kit: Desktop)
When executing step “Qbs Build”

Solved!

I was trying with the Github version.

I downloaded the version in the website and compiled it all normal, following the instructions, and everything just worked as it should.

At the end I don’t know what was wrong, if it was me or something about the nightly build. Well, it doesn’t matter.

liebe Grüße an alle,
Gil