Building in macOS 11.0 Big Sur

I get the app running but there are tons of errors in the buildtime slide, is that normal?

Hi, can you share the errors you are seeing?
Thanks!

sureee

Ah that is helpful. Thanks!

Those Warnings are normal.
Though the header map one is something we probably should address soon.

Theo

1 Like

Thank you theo! You are awesome!

@theo I’m very new in oF, can you give me a little guide of how achieve this?

Hi!

Try the nightly downloads for osx linked at the bottom of:
https://openframeworks.cc/download/

if you are using Apple M1 and building with make (VSCode) it worths installing make using homebrew, so you use arm-apple-darwin20.2.0 instead of i386-apple-darwin11.3.0

to make it work I had to edit ~/.zprofile file and add new make to the PATH variable
PATH="/opt/homebrew/opt/make/libexec/gnubin:$PATH"

1 Like

Hey theo! Im having a problem with audio, I think is because of the mac :(( when i try to run it marks an error in this line

FMOD_System_PlaySound(sys, FMOD_CHANNEL_FREE, sound, bPaused, &channel);

please help :frowning:

also i leave here a screenshot

Hi @EmilianoAlba54
We have found a maybe related issue with ofFmodSoundPlayer with the 0.11.1 release.

Can you see if the changes mentioned here fix the issue for you?

If they don’t could you share the most minimal ofApp.cpp example that triggers the crash and we can help you find a fix for it.

Thanks!!
Theo

Sorry to hijack this, but could someone with an M1 mac mini running a native M1 version of OF run the glInfo example included in OF, and post the full report here?

Thanks!

Hi folks,

Can anyone help me with this error here?

It happens after the build phase, and seems different to the linker error above.
I’m pretty stuck - I had to do the Big Sur update and now I can’t run any of my sketches at all…. Eeeek

S

Hello,
Now it works.

I am on Big Sur on Intel and I was getting the same dylib error.

After

  1. cloning master branch GitHub,
  2. running the sh libs script,
  3. and downloading the nightly build just for getting the compiled Project Generator,

it worked perfect.

Regards