Building for OSX 10.6 on 10.11

I need to compile an OF application for 10.6 on OSX. I am on 10.11 with xcode 8. I have downloaded the 10.6 SDK and am using OF 0.8.4, but when I try to compile I get this error

ld: library not found for -lcrt1.10.6.o

Pretty much everything I find says that this is either from not having the SDK or not having command line tools installed, and I have both of those things…

Any clues how I can do this without resurrecting a 10.6 machine?