Build OK but entry point not found-error (dll)


I installed OF on Windows 10 today following this example:

I set all the system path, rebooted, and compiled some OF examples.
But if want to run any compiled examples’ *.exe the following errors occur:

(…) entry point not found in C:\msys64\mingw32\bin\libboost_system-mt.dll"
(…) entry point not found in C:\OF\examples\gui\guiExample\bin\guiExample.exe
(…) entry point not found in C:\msys64\mingw32\bin\libboost_filesystem-mt.dll"
(…) entry point not found in C:\msys64\mingw32\bin\liblex-2_2.dll

If I use

make RunRelease

it says [RunRelease] error 127

Do you have any ideas?
Greetings, Himi

I had the same problems with entry points to dlls not found with the latest OF distro on Win 7 with QT. Here’s a quick solution, that worked for me: simply copy the dlls which can’t be found into your bin.

As you are compiling from the console, you can try “make copy_dlls”, this will copy all dlls from msys64 into the bin, which is a bit of an overkill, but an easy way to check out, if that approach works.
This was my thread:

You can use a script which automatically copies the necessary dlls. This is what I did on QT by modifying ofApp.qbs in libs/openFrameworks/Compiled/projects/qtcreator.

I’d be interested to hear if this approach worked for you!

(What puzzles me is that your guiExample.exe can’t be found either, so your problem might be different from mine, although we got the same error message regarding the dlls…)

That way it’s working. But I’m wondering because the error is not “dll not found …”.
It says “entry point not found in ***.dll”.
So I think it knows where the dll is but something else is wrong ?

From my understanding it practically means that the proper dll can’t be found via the system path. The reason could be a conflict with other versions of the same dll in other places of the system. Since the exe first searches in the bin, putting your dll there makes sure it can find the right version.