Build failed with ofxShader in Visual Studio

Hello,

I generated a new project and when hitting build on an empty project with no changes, I get this weird error. Looks like it wants to compile the README :slight_smile: Makes no sense to me :slight_smile:

I’m using Visual Studio 2019, Windows 10, and OpenFrameworks 0.11.0

hello,
i cannot test on windows right now.
if i am not wrong, then vs2019 support is still experimental and it is recommended to use vs2017. https://openframeworks.cc/setup/vs/
mabye you can remove the readme from your project or remove it from the filesystem and regenerate the project.
i just tested it osx makefiles, with no changes and it compiled.
hope that helps

I tried to delete it, but then it started to complain that it doesn’t exists :slight_smile: Then I truncated it and got another set of errors.

Thanks, I’ll try the downgrade.

I haven’t had issues with vs2019, usually just have to upgrade project target but all works fine.

this error looks like it’s trying to compile “readme.txt” – can you remove that file from your project?

Retarget worked unil I added this third party addon. My previous comment explained my failed attemtps :slight_smile:

Hi,

Here is a suggestion.

  • Make sure the readme.txt isn’t in the src/ folder.
  • Then run the project generator again and generate the project.

The problem is the readme.txt is getting added to the VS project, so when you delete the file the project complains that the file is missing.