Build error vboMeshDrawInstancedExample in v080


I tried to build vboMeshDrawInstancedExample in v080, but I got fatal error.

[ fatal ] App: glDrawElementsInstanced is needed for this example but it is not supported by your graphics card. Exiting App.

I tried same example in nightly build version. It was working.

I tested with MBPR and Macbook Air 2012 with moutain lion 10.8.4 and I got same error…

Is there anything I could change to solve this issue.

Thank you


if you got to main.cpp in the examples and comment out the check for the vbo draw instanced extension, does the app then run okay for you?

Thank you for replying to my question.

I uncomment “#define USE_PROGRAMMABLE_GL” , comment out the code below and I finally successed to compile it.

if( glDrawElementsInstanced == 0 ){  
    ofLogFatalError("App") << " glDrawElementsInstanced is needed for this example but it is not supported by your graphics card. Exiting App.";  
    return -1;   

Thank you for big help.


1 Like

No problem Koutaro,

Weird that it runs when glDrawElementsInstanced is not available.
I’ll file a github issue about this.


identical issue here. Included some more info that might be helpful.

looks like there is an issue with the way we’re checking the extension.
you can remove the check for now, we’ll make sure this is fixed in the next patch release.

I’ve filed an issue on github

Thanks for letting us know!!

same issue here, additional info
created after commenting check condition

gl info

opengl info  
vendor=NVIDIA Corporation  
renderer=GeForce GT 650M/PCIe/SSE2  
GL_VERSION_3_1:                                                OK   
  glDrawArraysInstanced:                                       OK  

Strange thing it works when starting directly(not starting from visual studio)

Hi everyone, I did the corrections suggested but I’m stil facing this error when trying to run this example. (It compiles perfectly)
I commented out what @theo suggested in main.cpp, #define USE_PROGRAMMABLE_GL. It didn’t work, then I commented out the same line in testApp.h, so I had the two lines uncommented in both files.
Finally I tryed commented out in .h but not in the main.cpp and viceversa. It didn’t work either. Any ideas? Thanks!

OS: Ubuntu 12.04 64 bits.
oF: 0.8.0
Graphic card: AMD
OpenGL version: 3.3.1

ps: If I comment the checking if in main.cpp, it works => it runs.
According to glInfo: glDrawElementsInstanced: OK

I appreciate any take of why this is happening.

Worked for me too!