Big Sur compile/run error/uhoh

Hello All,

I have an error when trying to run even the basic empty example file, having just had to finally submit to updating to Big Sur.

A screenshot is below - does anyone know what is causing this and how to solve it?

Sam

edit: it looks like this issue here: Thread error and no sketch window but I I have used the latest OF download…

Try to download the latest release to check if there is something bad with your installed OFW
https://openframeworks.cc/download/

yup I did do that

Plus have tried deleting everything and then downloading and using the nightly build. Exact same error on trying to run Empty Example….

Hi Sam.

What version of Xcode are you using?

Thanks!
Theo

Hey there!

I’m on XCode 11.3.1, on an Intel Mac with OS 11.4

S

Ahh.
I think you will need the latest Xcode for OF to run on Big Sur.
Try Xcode 13 and see if that works for you.

Cheers!
Theo

Thanks, I’ll give it a try. Looks like the update download is hefty so will be an overnight job….

Fingers crossed, will report back
S

I’m on macOS BigSur 11.6 and openFrameworks 0.11.2 runs great with XCode 13.0!
I haven’t tried version 13.1 yet.
There’s just a little annoyance, and that is that each time you generate a new project with the projectGenerator, you need to change it in XCode to the new build system, otherwise it won’t compile.
You can do that in the project settings (File > Project Settings …).

1 Like

I was just test on Xcode 13 and see the issue you mention @diff-arch – detailing here in case it’s helpful.

when you compile as is, you see this:

as you mentioned, this is the change that fixes things


cc @Theo – the template needs to be set to new build system by default?

3 Likes

This change can set the new build system as default

1 Like

Ok, so I have the latest Xcode now, and I’ve worked through the above issue on build system, but…

  • Examples that came with the new OF work fine
  • My old sketches I now get the following error:
dyld: Library not loaded: @executable_path/../Frameworks/libfmod.dylib
  Referenced from: /Users/smcelhinney/Dropbox/01_Openframeworks/apps/libApps/emptyExample/bin/emptyExampleDebug.app/Contents/MacOS/emptyExampleDebug
  Reason: image not found

Is there a fix for this?
S

if you update the project files of older sketches using the project generator and try cleaning and rebuilding, do you see that error? I think you may see something like this if you mix projects from older OF versions.

(Also I’d be generally cautious about using dropbox / iCloud or any syncing folder and OF – have had students with issues in the past keeping their OF folder in those kinds of locations)

Mmm I did wonder if dropBox was causing me issues right back at the start of this thread.

I’ve tried with the update via projectGenerator, and yes that fixes it for my basic sketches, thanks! Now just need to do the same for the more complex ones and then rebuild all the project settings, which is a bit of a pain but hopefully not impossible…

one quick note if it’s helpful, if you need to update a bunch of projects, is that the project generator has an advanced mode which updates recursively. it’s not enabled by default, but I’ll use it sometimes when I have a folder with a bunch of projects and I need to update them…

Ahh that’s pretty cool, I’ll check it out!

I am mainly trying to get one key project back up and working. It’s proving a little tricky as I had things like libiconv embedded. Almost there now I think, but the debug and release modes don’t seem to bundle the data files into /resources at the mo

S

uffffff. When I try and run with AppStore profile, I get the following error that I haven’t seen before…?

Entitlements:
211203_isovist.entitlements
Found:
/Users/smcelhinney/Dropbox/01_Openframework/Versions/A/s/apps/elevenApps/211203_isovist/bin/211203_isovist.app/Contents/Frameworks/libfmod.dylib
Stripping invalid archs '/Us'
fatal error: lipo: can't open input file: /Us (No such file or directory)
Signing '/Us'
/Us: No such file or directory
Failed to sign '/Us'.
Command PhaseScriptExecution failed with a nonzero exit code

I’ve been using Syncthing to sync a folder between multiple computers and it is pretty good at keeping metadata of files intact. I can even run the app in different machines without the translocation hassle. It is free, open source and peer to peer. no central server.

Cool, I’ll take a look.

I have debug and release versions working fine now, it’s just the AppStore one that is left and which calls the above error. I guess it is because that’s the only one that calls the ‘stripping invalid archs’ script during the build phases…? But I don’t know how to track that issue down myself

do you have that issue with all projects (ie, the ones that come with this version of OF )