Beware! OS X Mountain Lion 10.8 broke my oF 0071

Hello everyone!
I’m very new to OS X but not new to openF. It seems there are a few threads about some problems like this. In summary, updating to the oficial release of Mountain Lion forced me into updating Xcode which seems to have broken my openF 0071 projects. It seems to be missing an SDK which is mentioned in this thread ( http://forum.openframeworks.cc/t/xcode-4.5-not-supporting-10.6-sdk/10343/0 ) but copying that SDK didn’t work for me.
I also tried uninstalling the new Xcode and installing the older one but the older one won’t work on Mountain Lion, it will actually complain about it.

I guess I wasn’t expecting this update to break anything, now I know. :frowning:
Does anybody know how to correctly downgrade without having to install everything from scratch?
Any update on this situation or anything one should know about these sorts of upgrades?
Thanks everyone :smiley:

I just added the SDK on my new machine and it worked for me. Are you sure you are doing it right? I followed obviousjim’s advice here:

http://forum.openframeworks.cc/t/xcode-4.5-not-supporting-10.6-sdk/10343/0

Downloaded his 10.6 SDK
http://www.jamesgeorge.org/uploads/MacOSX10.6.sdk.zip

put it here:
/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.6.sdk

That worked for me.

Sure did, but I’ll try it again now. :slight_smile:

Not sure if this will help, but changing the base SDK in the build settings for openFrameworks to 10.6 is also necessary. (3rd line down under build settings, make sure you have ALL selected). You may also need to change the deployment target of your project to 10.6 as well.

That second suggestions seems to have worked. :stuck_out_tongue:
Thank you :slight_smile:

changed the base OS to 10.6 like brettburton said and it works great for me

Great, this works for me too!

x-code 4.4, os x 10.8.1

I knew that loitering around in forums would do me good one day :stuck_out_tongue:

Solved the problem right after it happened, Thank you!

Hi. I am sorry if it’s a little offtopic…

I have a new machine with 10.8.4 without Xcode or OF installed yet.
Until now, I am working with OF 0.7.4 and Lion 10.7.3.
Also, I would like to compile to iPad 6.1.2 iOS too.

I want to know what’s the best working version to install, without breaking my project.

Regards

edit:
ML 10.8.4 & Xcode 4.6.3 + command tools + 10.6 SDK seems working fine here too.