Beginners problem: connot open shared object file / libpsl-5.dll missing

Hello everybody,
I’m having problems setting everything up on a windows pc. I’ve tried reinstalling several times and read everything remotely related to my error I could find on google, but I couldn’t solve the problem.
After installing msys (tried various builds) I can compile projects, but they won’t run because libpsl-5.dll is missing - thats the windows error running the file, in mingw it says error 127.

make run

HOST_OS=MINGW32_NT-10.0-WOW
checking pkg-config libraries: cairo zlib openssl glew glfw3 libcurl
with PKG_CONFIG_LIBDIR=
D:/ofx/examples/3d/3dprimitivesexample/bin/3dprimitivesexample.exe: error while loading shared libraries: ?: cannot open shared object file: No such file or directory
make: *** [/d/ofx/libs/openFrameworksCompiled/project/makefileCommon/compile.project.mk:192: run] Error 127.

Maybe somebody has an idea! Thanks in advance

Sometimes some msys2 update breaks the OF dependencies, if it’s that it might be just a matter of waiting a few days and updating to see if a new update fixes the problem.

You can also try using visual studio instead of the msys version

1 Like

thanks arturo, I will check back in a few days!