Augmented Reality on Windows

Hi all

i read this post
http://forum.openframeworks.cc/t/augmented-reality/743/0

and i download the ARToolKitManeger por 005 here
http://www.openframeworks.cc/files/005- … TKPlus.zip

i tried all the ways

i used like a addon
i used like libraries
i put it by hand

but always apper arround 200 error

whe i thing that i find the way, apper an erro, like, this library doesn’t exits.

all the examples be for MAC

if anyone can make this real for windows, can helpme to sayme what is the way, i not need the project i can make ir but i can`t upload this toolkit for OF.

THX ALOT

Hi

I got ARToolKitManager working in VisualStudio 2008. This one is for 0.05 but i got it working in 0.06 as well.

Just place ARToolKitManagerExample in your examples folder and ofxARToolKit in your addons folder. Then compile.

http://www.2shared.com/file/6040985/ada-…–VS08.html

I hope this works for you.

wow :smiley:

in codeblock apper this error in :slight_smile: again :slight_smile:

Take care
john

Hi there… I´m having the same problem when trying to compile ARToolkitPlus 2.1.1 as addon in win32 SP3 with OF 0061 and code blocks 10.05.

this is the error i’m having:

F:\openframeworks\0061_win_cb_FAT\addons\ofxARToolkitPlus\src\TrackerImpl.cxx|54|error: ‘AR_TEMPL_FUNC’ does not name a type|

[attachment=0:37qcfbjg]of_cb_artkp.jpg[/attachment:37qcfbjg]

any clue on how to solve this one?

thxs!

Same problem here! I’ve added everything and also linked everything but still i get a compile error i have no idea why this happens, ofxFiducialFinder works fine. codeblocks 10.05, OF-0061FAT any adieas?

thank you,
Sonic

i forgot to post the code :

  
AR_TEMPL_FUNC bool  
AR_TEMPL_TRACKER::calcCameraMatrix(const char* nCamParamFile, int nWidth, int nHeight, ARFloat nNear, ARFloat nFar, ARFloat *nMatrix)  
{  
	CameraFactory cf;  
	Camera* pCam = cf.createCamera(nCamParamFile);  
	if(pCam == NULL)  
	{  
		return(false);  
	}  
  
	pCam->changeFrameSize(AR_TEMPL_TRACKER::screenWidth,AR_TEMPL_TRACKER::screenHeight);  
  
	int i;  
    for(i = 0; i < 4; i++ )  
        pCam->mat[1][i] = (pCam->ysize-1)*(pCam->mat[2][i]) - pCam->mat[1][i];  
  
	ARFloat glcpara[16];  
  
    if(!convertProjectionMatrixToOpenGLStyle((ARParam*)pCam, nNear,nFar, glcpara))  
		return false;  
  
	// convert to float (in case of ARFloat is def'ed to doubled  
	for(i = 0; i < 16; i++ )  
		nMatrix[i] = (ARFloat)glcpara[i];  
  
	return(true);  
}  
  

and the compiler errors:

  
||=== opencvExample, release ===|  
..\..\..\addons\ofxARToolkitPlus\include\ARToolKitPlus\config.h|231|warning: "MAX_PATH" redefined|  
c:\program files (x86)\codeblocks\mingw\bin\..\lib\gcc\mingw32\4.4.1\..\..\..\..\include\stdlib.h|45|warning: this is the location of the previous definition|  
..\..\..\addons\ofxARToolkitPlus\include\ARToolKitPlus\..\..\src\TrackerImpl.cxx||In constructor 'ARToolKitPlus::TrackerImpl<__PATTERN_SIZE_X, __PATTERN_SIZE_Y, __PATTERN_SAMPLE_NUM, __MAX_LOAD_PATTERNS, __MAX_IMAGE_PATTERNS>::TrackerImpl()':|  
..\..\..\addons\ofxARToolkitPlus\include\ARToolKitPlus\..\..\src\TrackerImpl.cxx|66|note: #pragma message: >>> not using SinCos LUT|  
..\..\..\addons\ofxARToolkitPlus\include\ARToolKitPlus\TrackerImpl.h|636|error: invalid use of member 'ARToolKitPlus::TrackerImpl<__PATTERN_SIZE_X, __PATTERN_SIZE_Y, __PATTERN_SAMPLE_NUM, __MAX_LOAD_PATTERNS, __MAX_IMAGE_PATTERNS>::screenWidth' in static member function|  
..\..\..\addons\ofxARToolkitPlus\include\ARToolKitPlus\..\..\src\TrackerImpl.cxx|449|error: from this location|  
..\..\..\addons\ofxARToolkitPlus\include\ARToolKitPlus\TrackerImpl.h|636|error: invalid use of member 'ARToolKitPlus::TrackerImpl<__PATTERN_SIZE_X, __PATTERN_SIZE_Y, __PATTERN_SAMPLE_NUM, __MAX_LOAD_PATTERNS, __MAX_IMAGE_PATTERNS>::screenHeight' in static member function|  
..\..\..\addons\ofxARToolkitPlus\include\ARToolKitPlus\..\..\src\TrackerImpl.cxx|449|error: from this location|  
||=== Build finished: 4 errors, 2 warnings ===|  
  

i found the way to solved
reference:
http://www.rojtberg.net/318/artoolkitplus-2-1-3/
source:
cb projected
singlemarker
http://www.filedude.com/download/eAao233RXna8a830229f
multimarker comes later

Hey,
did anyone get this to work? I had the same issue with the AR_TEMP function

I tried the ARToolkit2.20 link and compiled a new set with that, the camera shows up, but I am not to sure if its actually drawing anything, or where it is referring to a specific marker…

anyone get this going?

OS - windows 7 (64 bit)
Codeblocks. 10.5

Ok, I got it working in codeblocks!
However this uses the BCH markers and not the markers like ARToolKit uses in which your able to make your own as .patt files.

For example the simpletracker tutorials use hiro.patt as a reference.
Does anyone have that tutorial working with code blocks?
Thanks

hello,
fishkingsin did you happen to get multi to work at all?
-m

sorry for my late reply

I dont have much I am still solving the problem
i got this problem at

  
#0 6BFA0C40	ARToolKitPlus::calcArea() (F:\of_preRelease_v0062_win_cb_FAT\apps\addonsExamples\ofxARToolkitPlusExample\bin\libARToolKitPlus.dll:??)  
#1 6BFA0F2A	ARToolKitPlus::maximizeArea() (F:\of_preRelease_v0062_win_cb_FAT\apps\addonsExamples\ofxARToolkitPlusExample\bin\libARToolKitPlus.dll:??)  
#2 6BF97E04	ARToolKitPlus::Tracker::arMultiGetTransMatHull() (F:\of_preRelease_v0062_win_cb_FAT\apps\addonsExamples\ofxARToolkitPlusExample\bin\libARToolKitPlus.dll:??)  
#3 6BF8581C	ARToolKitPlus::Tracker::executeMultiMarkerPoseEstimator() (F:\of_preRelease_v0062_win_cb_FAT\apps\addonsExamples\ofxARToolkitPlusExample\bin\libARToolKitPlus.dll:??)  
#4 6BF86317	ARToolKitPlus::TrackerMultiMarker::calc() (F:\of_preRelease_v0062_win_cb_FAT\apps\addonsExamples\ofxARToolkitPlusExample\bin\libARToolKitPlus.dll:??)  

here is the both source of multi marker ans single marker
single marker is working fine
but muti marjker is not work
and i cant figure out the problem

develop under :

of_preRelease_v0062_win_cb_FAT
windwo codeblock 10.5

src:
http://fileape.com/dl/gXvTGiPMr9bK2moD
could anyone helps to make it works
thank you

note :
i compile the .a library from
https://launchpad.net/artoolkitplus/+download
i use cmake to gen a cbp project to build the C::B library
http://fileape.com/dl/IAiDJCJIjBoBHlvN