audioInputExample for iOS doesn't work on OF release 0.9.8

I tried the audioInputExample for iOS but it doesn’t work.

Actually I could run the app and play the sound.
But I could not get the volume from input.
Of course I called the setup function for sound stream like below.
ofSoundStreamSetup(0, 1, this, sampleRate, initialBufferSize, 1);

Actually I added below in Info.plist but that’s it.
Privacy - Microphone Usage Description : Sound stuff

Does anyone have an idea?

My environment is below

  • iOS 11.1.2(iPhone6s)
  • openFrameworks 0.9.8

Thanks.

I solved it.

Hi! If you share how you did it it might help others :slight_smile:

I’m not sure but it worked when I commented out related to the sound object (ofSoundPlayer instance).
Does anyone know the problem?
If so please tell me.

Thanks.

Hi I created the new topic because I think this issue is not solved…

I just confirmed latest nightly build (of_v20180502_ios_release) has no problem above. Both input and output of the sound works correctly on the audio input example.