audio stuttering aoss issue

I’ve been having some problems with audio playback stuttering. After searching around, I tried this fix:

http://forum.playgreenhouse.com/jforum/-…-5/260.page

installing alsa-aoss and running the app from the command line prefixed with aoss

that works perfectly, but I’m wondering if there is a way to fix this so I don’t have to run from the command line…

oss is the old linux sound system replaced time ago by alsa, but some apps yet use oss or work better with it.

aoss is a wrapper around oss that converts oss api to alsa calls, there’s another package that should do the same but automatically without using nothing in command line:

apt-get install oss-compat

if that doesn’t work, as in linux you need the clickToLaunchApp.sh script to run apps, you can edit the script in the export directory to execute your app using aoss:

  
#!/bin/sh  
  
echo $(pwd)  
export LD_LIBRARY_PATH=$(pwd)/libs/  
aoss ./applicationName  

thanks again!

the oss-compat didn’t work for me, but the aoss is ok for the moment. unfortunately, aoss seems to create horrible freezes/crashes when exiting the app… so i have to find a some better solution when i have more time. i am curious, do you suppose it is the fmod lib that is choosing to use the older oss system instead of alsa? i have all my system sound settings set to alsa (as far as i can tell)

Hi chris

with this line you should be able to change the output system:

  
  
FMOD_System_SetOutput(sys,FMOD_OUTPUTTYPE_ALSA);  

put it in line 145 in soundPlayer.cpp in the initializeFmod function after

  
FMOD_System_Create(&sys);  

I think the supported systems for linux are:

FMOD_OUTPUTTYPE_ALSA
FMOD_OUTPUTTYPE_OSS
FMOD_OUTPUTTYPE_ESD

Hi Chris,
FMOD uses OSS by default on Linux unless you specify otherwise…so the best thing would be to follow arturo’s instructions above!