Attempting to cross-compile OF for RPI3 Raspbian Stretch

#1

Hi there,

I’m trying to learn how to cross-compile on my Mac running OS X 10.13.3 for my Raspberry Pi 3 B+ running Stretch.

I’ve tried doing this using the VM method outlined in this thread: Cross compiler for OF 0.9.0/Jessie/arm6/RPi1, but I got stuck on the step where I had to actually mount the RPI as a network drive on the VM (however, mounting on my Mac works fine).

I’ve found another resource online for cross-compiling that provides a precompiled toolchain here: Cross compiler for OF 0.9.0/Jessie/arm6/RPi1

Using the guide outlined here: https://openframeworks.cc/setup/raspberrypi/raspberry-pi-cross-compiling-guide/ I tried running this command:

make TOOLCHAIN_ROOT=/Volumes/xtools/armv8-rpi3-linux-gnueabihf/bin GCC_PREFIX=armv8-rpi3-linux-gnueabihf RPI_ROOT=/Volumes/Data/home/pi

Which produces this error:

HOST_OS=Darwin
/Volumes/Data/home/pi/openFrameworks/libs/openFrameworksCompiled/project/makefileCommon/config.shared.mk:86: *** commands commence before first target.  Stop.

I’m very new to this so I’m sure there’s something very obvious that I’m doing wrong. I would rather compile the code on my mac without having to use a VM if possible. Could anyone point me in the right direction?

EDIT: I’m taking a look at the steps here in the meantime: https://openframeworks.cc/setup/raspberrypi/raspberry-pi-cross-compiling-guide-wheezy/

#2

I did something similar for Stretch a while back (still using a VM however). I was planning on creating an updated post but haven’t done it yet. It’s similar to the original and the scripts/rough notes are here (see the comments)