AssimpLoader and materials

Is it just me or is there something wrong with materials in ofxAssimpLoader.

I’m just trying to display some simple meshes with some colored materials. I’ve tried different file formats but no success. It 's just display dull gray. I’m doing nothing fancy:



But whatever I try I can’t get them to show their color.

    material = model.getMaterialForMesh(0);  


OF: OF_LOG_VERBOSE: 0.237082, 0.64, 0.204883, 1  
OF: OF_LOG_VERBOSE: 0, 0, 0, 1  
OF: OF_LOG_VERBOSE: 0, 0, 0, 1  
OF: OF_LOG_VERBOSE: 0.5, 0.5, 0.5, 1  

So it has found colors

This shouldn’t be so hard should it?



I haven’t tried this out yet… but have a look at this.

This might fix the color materiels issue.

Yep I’ve seen that thread. But it is just a workaround for some trouble inside the assimploader.

So I’d rather get to the bottom of this. :slight_smile:

I have just tested and replicated this same problem on OSX 10.6.8.

If I just assign a material to an object and not a texture it shows up “overlit” white in de OF.

Agreeing with Sphaero I would also lik to get to the bottom of this.
Any help would be appreciated.


Just checking… could you guys find a solutions to this problem?

I am also facing a similar issue on OSX 10.6.8 :slight_smile:


Nope although we might have. It’s just we’re working around multiple problems that I’m not keeping track currently.
Since we are using textures the problem sort of goes away. However with textures we’ve found trouble as well. We’re now just doing the draws by hand.

Yeah… I tried the workaround mentioned here

I could load the model with correct colors but some parts of the model were transparent (see through) :-/

I think we really should look into ofxAssimpLoader and try to find a permanent fix for this. I am sure the model loads correctly with the assimp library (outside OF).

Sorry I was wrong. That workaround fixed the most issues. I got the transparent-faces issue as I was drawing the 3D model on an FBO. That is again a totally different issue. :slight_smile: