arduino firmata example

Just picked up OF and I must say I am impressed…

But now I have a problem. I am trying to connect to an arduino with the firmata example.
Since I am usually using a mac I tried it on mac first and it worked just fine, but
now I need to do a project on windows XP and it won’t work.

I am able to make the arduino blink using the arduino application, so I guess
the arduino is set up correctly.

Since my arduino is on COM5 port i changed this in the firmata example:

ard.connect(“COM5”, 57600);

but when I run it, it just says: Arduino not ready…

the console says:
ofSerial: listing devices <2 total>
[0] = COM1
[1] = COM5

any help would be very much appreciated… Thanks

ok I solved it… stupid mistake

1 Like

it would help future users happening upon this thread if you would describe the mistake and the solution…

reference: :wink:

:slight_smile: … Like

Yeah sorry. I felt like the guy in the comic a lot of times myself :slight_smile:

Well it turned out that it was not my stupid mistake after all. After searching a bit more
in the forum I found this thread describing the same problem I had:

I ended up downloading OF v. 062 and it works fine on my xp setup.
So I will just go with that version for now…

1 Like