Application won't start after Ubuntu upgrade


So I just upgrade to Ubuntu 14.10 and the change seems to have broken my dev environment. Everything compiles alright but when I run an OF application no window is ever created and nothing happens: no logging or anything. The process just hangs.

I created a new project with the Project Generator and just had that log something in setup() but still nothing. I then ran that program through gdb and got a backtrace:

#0  0x00007ffff4a43380 in __poll_nocancel () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fffefe15b72 in ?? () from /usr/lib/x86_64-linux-gnu/
#2  0x00007fffefe1764f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/
#3  0x00007ffff62703a8 in _XReadEvents () from /usr/lib/x86_64-linux-gnu/
#4  0x00007ffff6258889 in XIfEvent () from /usr/lib/x86_64-linux-gnu/
#5  0x000000000058396b in createWindow ()
#6  0x000000000058545f in _glfwPlatformCreateWindow ()
#7  0x000000000057dcff in glfwCreateWindow ()
#8  0x000000000042c5d0 in ofAppGLFWWindow::setupOpenGL (this=0xa75990, w=1024, h=768,     screenMode=OF_WINDOW)
    at ../../../libs/openFrameworks/app/ofAppGLFWWindow.cpp:198
#9  0x0000000000418e26 in ofSetupOpenGL (windowPtr=std::shared_ptr (count 3, weak 0) 0xa75990, w=1024, h=768, screenMode=OF_WINDOW)
at ../../../libs/openFrameworks/app/ofAppRunner.cpp:274
#10 0x00000000004195c9 in ofSetupOpenGL (w=1024, h=768, screenMode=OF_WINDOW) at ../../../libs/openFrameworks/app/ofAppRunner.cpp:328
#11 0x000000000041648e in main () at src/main.cpp:10

I’m honestly not really sure what to make of this. It seems like it’s trying to create the window for the application but cannot do it for some reason.

I tried switching back to GLUT as mentioned in this thread but that didn’t change anything. Same backtrace and everything.

Anyone have any ideas? I’m going to keep trying things but I’m totally dead in the water here. Thanks in advance.

So I’ve done some more tests. I tried running the install_dependencies scripts again and those run fine. Next I tried to do a simple test with GLFW since it seems like that’s where the OF applications are getting stuck.

I ran a simple GLFW example that should just create a window and it got stuck too with a similar backtrace and without creating a window. It seems to me that for whatever reason GLFW can’t create new windows for me.

Is anyone else on Ubuntu 14.10? Has anyone else ever had a problem creating a window? I’m not sure what else to do or even how to debug this. Any help would be greatly appreciated.

this is a bug in unity, by now you can use a glut window or switch to gnome or any other window manager. i’ve opened a bug in the unity issue tracker and glfw:

and someone is taking care of it but it’s been a couple of weeks already so not sure when it’ll be fixed

Okay, Looks like I made a mistake switching to GLUT before. I just tried it again and now the applications are running! Still not sure what the deal with GLFW is but I guess I’ll just ignore it for now.

Gotcha. Thanks @arturo!

According to the bug report the fix was released but in a current updated installation of Ubuntu 14.10 the problem persists.

yes the fix was released but only in 14.04 (the latest LTS) and in 15.04 not in 14.10

Ooh, ok. I wasn’t aware that 15.04 got released. Will update to that.