Apple Mach-O Linker (Id) Error with ofxGui

I’m getting these errors after adding ofxGui. It would appear that it’s adding the header file correctly (i’m including the ofxGui/src in the header search paths), so i can’t figure out what is causing this problem. Any help would be greatly appreciated. Details:

ld: warning: ignoring file /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.12.sdk/System/Library/Frameworks//QuickTime.framework/QuickTime.tbd, missing required architecture x86_64 in file /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.12.sdk/System/Library/Frameworks//QuickTime.framework/QuickTime.tbd
Undefined symbols for architecture x86_64:
“ofxBaseGui::draw()”, referenced from:
ofApp::draw() in ofApp.o
“ofxBaseGui::ofxBaseGui()”, referenced from:
ofxToggle::ofxToggle() in main.o
“ofxBaseGui::defaultWidth”, referenced from:
ofApp::setup() in ofApp.o
“ofxBaseGui::defaultHeight”, referenced from:
ofApp::setup() in ofApp.o
“ofxPanel::setup(std::__1::basic_string<char, std::__1::char_traits, std::__1::allocator > const&, std::__1::basic_string<char, std::__1::char_traits, std::__1::allocator > const&, float, float)”, referenced from:
ofApp::setup() in ofApp.o
“ofxToggle::setup(std::__1::basic_string<char, std::__1::char_traits, std::__1::allocator > const&, bool, float, float)”, referenced from:
ofApp::setup() in ofApp.o
“ofxPanel::~ofxPanel()”, referenced from:
ofApp::ofApp() in main.o
ofApp::~ofApp() in ofApp.o
“vtable for ofxToggle”, referenced from:
ofxToggle::ofxToggle() in main.o
NOTE: a missing vtable usually means the first non-inline virtual member function has no definition.
“ofxGuiGroup::add(ofxBaseGui*)”, referenced from:
ofApp::setup() in ofApp.o
“ofxBaseGui::~ofxBaseGui()”, referenced from:
ofxToggle::ofxToggle() in main.o
“ofxToggle::operator bool const&()”, referenced from:
ofApp::update() in ofApp.o
ofApp::draw() in ofApp.o
“ofxPanel::ofxPanel()”, referenced from:
ofApp::ofApp() in main.o
“ofxToggle::~ofxToggle()”, referenced from:
ofApp::ofApp() in main.o
ofApp::~ofApp() in ofApp.o
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)

-My xcode version is “8.32”
-My OS is “OSX Sierra 10.12.4”
-My OF version is “of_0.97_osx_release”

Thanks in advance!