AppImage to package a released app

Hi everyone! :wink:

I’m trying to package the release of my app to get a self contained package that runs on any machine in the future.

I’ve tried to create an AppImage but it still looking for the shared libraries in the /usr/lib of the system and not from the /usr/lib of the AppImage.

please see this post in the AppImage forum

Any idea of how to get a release version packaged?

Thanks in advance!

I have solved the isuue on my own, but the problem I’m facing now is
the app released doesn’t run in another OS, it shows and error core dumped

that might be how did you fixed ?, and the new error just says core dumped?

it is possible to create and AppImage fully functional with a released OF app, in the App dir you NEED TO create the AppRun with these lines:

#!/bin/bash

APPDIR="$(dirname "$(readlink -f "$0")")"
export LD_LIBRARY_PATH="${APPDIR}/usr/lib"

exec "$APPDIR/path_to_your_application"

Below the shebang:
The first line locates the tmp AppDir folder mounted when the AppImage runs.
The second line points the system to the /usr/lib/ of the AppDir, so the shared libraries will be loaded only from the AppDir of the AppImage.
The third line executes your app from its path within the AppDir.

But my actual problem isn’t related to the AppImage rather from OF itself, so at the end my binary shows:

*** stack smashing detected ***: terminated
Aborted (core dumped)

Any help on this will be highly appreciated!

Solved!

The problem was glibc, the library on the PC where the application will be run must be a version equal to or greater than the one it was compiled with.

The error was displayed because the glibc version on the PC to run the application was lower than the one it was compiled with.

1 Like