App no longer opens on other OSX machines

Hello again all,

I have an app that I have been working on for 2+ years for OSX - I host it on my website as a zip file for download.

Since I’ve moved to OF v11, when I (or anyone else) tries to download and run the app, I get the following message:

app is damaged and can’t be opened. You should move it to the Trash.

How can I fix this? Is it code signing related??


Hi, which version of macOS are you on?

You might need to disable code signing as described here:

I think if you are signing the app for development ( which is the default now ) it might error on other machines.

Going forward if you want to distribute your Mac App ( and even currently if you don’t want warnings when users open it ) you’ll need to sign the app for distribution ( and starting in 10.15 notarize it too ).

1 Like

hey, thanks for the reply…

I’m on Mojave, 10.14.6; but others who use the app are on 10.15 as well I think.
Is there a (idiot proof) guide to signing an app and notarising it in OF? I’m totally new to all of that


edit: I don’t think it is the linked issue, I’ve tried that and I still get the warning. I think it is probably Gatekeeper blocking the app from running because of signing, which I’m a bit lost on how to do properly.

I think it is all covered here:

It is the same for OF and any other app made in Xcode.

thanks… I think!
Seems quite a bit beyond what I am familiar with.

edit: (having read up) Am I right to think that I have to pay ££ to Apple in order to get a developer membership, or it is no dice?


Yes, sadly as things currently stand from 10.15 onwards ( after an update in Jan 2020 ) you will need to pay Apple $99 a year to distribute outside of the AppStore.

For now I think if you do Build->Clean from the menu and change the “Sign to run locally” to nothing as in Todd’s post you should be able to run the app on other platforms by right clicking or control clicking on it and selecting open. That should allow you to bypass the Gatekeeper restrictions.

this could be related to translocation problem.
There is some topic related to this:
I am using this app (dmg canvas) to make a simpler .dmg:

@moebiussurfing thanks for this, but I’m pretty sure my data files and so forth are fine, I bundle them up into the app and include: ofSetDataPathRoot("../Resources/data/");

@Theo I’ve tried the blank ‘sign to run locally’ option and yes, this now runs on other Catalina installs (with a little help from right click, open). Thanks for this, I was a bit panicked!

I guess I have to ask Father Christmas for an Apple developer licence. That stings more than a little bit, given I give the app away for free. Might there be any issues with signing and notarising an app with things like shaders, csv data file loads, etc included in it? I’m worried that I end up shelling out the ££ and still can’t fix the problem.

Hey @Sam_McElhinney_io. I am not sure… but maybe you can take a look to the translocation problem. just in case… It’s not related to where the data is located, inside or outsite the Sorry to say it again but I had the same problems (in 10.13 not Catalina like you…) and that links solved them for me.

Hey, has anybody experience with the current situation?
Is it possible to distribute apps (or rather sketches and prototypes) compiled on 10.14 (or even 10.15) without an active dev account and the notarization stuff and have them run on Catalina?

I’m not sure if this helps, but I have built (without using an Apple Developer account) on Mac OS OSX 10.13 using xcode 9.4.1 and OF 10, and the build runs on Catalina, with the only warning being a dialog that asks for permission to access files.

Thanks for the info.
Seems it is still possible to force open apps via the dialog that way.
There were some changes in January by Apple, but I wasn’t sure if they just hardened the requirements for their notarization, or disabled running unsigned apps completely. :thinking:

Yeah, Apple requirements to be allowed to develop for their machines are about the most artificially complex I’ve ever seen.

I got to what I hope is the last step of the amazingly-baroque process of getting an iOS app ready for the Apple Store, and then discovered that with the current requirements, it would simply not let me complete the process without a later version of the SDK, which is only possible with a later version of xcode, which requires updating the OS to OSX 10.14 or 10.15… which my Mac is not allowed to do based on its age… so I had to acquire a newer Mac… though not for any actual technical reasons, just because it’s not permitted.

1 Like

I installed Hackintosh on my Ryzen 7 PC :wink: Just saying :slight_smile:

Interesting, though my replacement Mac is on its way.

Have you been able to get Apple to accept your Hackintosh as a Catalina development / codesigning machine?

I haven’t tried yet to send any update for my app from Ryzentosh Catalina, but I definitely had successfully from Ryzentosh Mojave.

1 Like

This worked for me building on Monterey and running on another Monterey computer, though I had to run

sudo spctl --master-disable

in Terminal on the other computer to bring back the “Allow apps from Anywhere” option in Security prefs.