Anyone successfully using OF 0.9.7(or 0.9.8) with msys2/Qt Creator on Windows?

it looks like so many users have failed to use OF 0.9.7 or 8 with msys2/Qt Creator version. is there anyone successfully using it on Windows 10 or any other windows system?

if so, what you did is only following the setup guide and everything worked smoothly?

if someone can share his/her experience it would be really appreciated.

there’ were some bugs in 0.9.7 but they where fixed in 0.9.8. can you post what error are you getting?

thanks for reply

I’ve managed to compile .exe file with Mingw and it works!

However, Qt Creator still not working with this error


… C:/Works_S/openFrameworks/of_v0.9.8_msys2_release/examples/3d/pointCloudExample/…/…/…/libs/poco/lib/msys2/libPocoUtil.a C:/Works_S/openFrameworks/of_v0.9.8_msys2_release/examples/3d/pointCloudExample/…/…/…/libs/poco/lib/msys2/libPocoJSON.a C:/Works_S/openFrameworks/of_v0.9.8_msys2_release/examples/3d/pointCloudExample/…/…/…/libs/poco/lib/msys2/libPocoXML.a C:/Works_S/openFrameworks/of_v0.9.8_msys2_release/examples/3d/pointCloudExample/…/…/…/libs/poco/lib/msys2/libPocoFoundation.a -lz -lglew32 -lopengl32 -lgdi32 -lmsimg32 -lglu32 -lwinmm -lstrmiids -luuid -loleaut32 -lsetupapi -lwsock32 -lws2_32 -lIphlpapi -lComdlg32 -lfreeimage -lboost_filesystem-mt -lboost_system-mt -lfreetype -lcairo -lpthread -lrtaudio -lksuser -lole32 -ldsound
C:/msys64/mingw32/bin/…/lib/gcc/i686-w64-mingw32/6.2.0/…/…/…/…/i686-w64-mingw32/bin/ld.exe: cannot find -lrtaudio
collect2.exe: error: ld returned 1 exit status
Process failed with exit code 1.
The following products could not be built for configuration qtc_msys_73395eec-debug:
pointCloudExample
Error while building/deploying project pointCloudExample (kit: msys)
The kit msys has configuration issues which might be the root cause for this problem.
When executing step “”

I tried both g++ and gcc.exe compiler in mingw32/bin directory, but it shows the same error

If you have any tips it would be really appreciated

that’s really strange can you post the file: libs/openFrameworksCompiled/project/qtcreator/modules/of/of.qbs if you are using 0.9.8 it shouldn’t be adding rtaudio like that

Hi,

I’ve got the same error message when I try to compile examples\sound\audioInputExample. The compilation with the msys make command is OK, but fail with QtCreator.

OF 0.9.8, windows 7, qtcreator 4.1.0.
(Note: one month ago I had a similar problem with OF 0.9.7, so my msys2 and qtcreator installations are 1 month old, and I just follow the update instructions in the setup guides)

Here’s the file of_v0.9.8_msys2_release/libs/openFrameworksCompiled/project/qtcreator/modules/of/of.qbs
of.zip (3.8 KB, zipped because of the forum restrictions)

Many thanks to you guys for all your work. It seems to be a pain to make a multi-platform project like the great
OF !

it seems there was a problem with the 0.9.8 package can you try downloading it again

1 Like

Thanks Arturo!

I downloaded it again and now it works on Qt Creator!

cheers

Thanks !