Anti-aliasing not working on Windows

I’m working on an app that needs to run on Windows XP, but as I’m on a Mac, I’m doing most of the coding in Xcode, then switching over to Visual C++ 2008 every once in a while to recompile. It’s working great, haven’t had to change anything in the code so far, but I just realized that anti-aliasing isn’t working on the Windows version.

Here are some screenshots:

Awesome on OS X

Crappy on Win XP


  • I’m using oF 0061 (it’s an old project and I’d rather not have to update it).

  • I’m using the GLUT display string “rgb alpha double samples depth” and have ofEnableSmoothing() in my testApp::setup().

  • The shapes aren’t actual 3D, they are just triangles:

        ofSetColor(edgeColorFar1.r, edgeColorFar1.g, edgeColorFar1.b);  
        glVertex2f(CENTER_X, CENTER_Y);  
        ofSetColor(edgeColorNear1.r, edgeColorNear1.g, edgeColorNear1.b);  
        glVertex2f(x - _dim, y - _dim);  
        glVertex2f(x + _dim, y - _dim);  

Any ideas? Thanks!

have you tried with "rgb double depth alpha samples>=4 "

I just tried that and it’s working fine on OS X but making my app crash at startup on Win XP. No useful debug info either, just “The program has exited with code 1 (0x1).”

where do you set the rgb double depth alpha samples?

In main, before ofSetupOpenGL(…):

int main(int argc, char *argv[]) {  
    ofAppGlutWindow window;  
    window.setGlutDisplayString("rgb alpha double samples depth");  
    ofRunApp(new testApp());  

Hey there,

We’re trying to get multisampling on windows to work also, and are having trouble. If anyone has gotten this to work with the latest OF tips would be helpful.


you can try with glfw, i posted a ofAppGLFWWindow class and instructions on how to use it here:

this is for linux but should work on windows too.

you can download glfw for windows from here:

you’ll need to link your program against the static library mingw or vs2010 depending on what you are using and then put the dll in the bin directory of your app

Just realized I never posted my solution here. It was actually non-OF: I had to switch the NVIDIA Image Settings from “Let the 3D application decide” to “Use my preference emphasizing:”, and then cranking up the quality on that slider.