androidEmptyExample OFActivity.java not creating .class files

Hi all,
I’m new to OF+android development, but handy on each individually :slight_smile: That said, i’m having trouble getting the examples to run successfully in the emulator or a device, though I can build the OFAndroid library and build & install all the example APKs … I run into java.lang.ClassNotFoundException errors upon launch.

I’ve ruled out many eclipse-rated project issues via StackOverflow debugging, and it basically comes down to I dissembled my classes.dex file and found no hint of the main OFActivity.class. Also when I look at my build tree, I don’t see any classes in the bin/classes folder …

I’m expecting the bin/classes folder to have .classes that are then dex-ified, and hunting through the makefiles hasn’t been forthcoming. Any ideas on how to proceed? I.e. my OF androidEmptyExample srcJava under which my OFActivity.java lives to be bytecode compiled into .class file.

Thoughts, sage advice? Is there a classpath issue here?

OS: MacOS 10.7.5
IDE: v21.1.0-569685
Android API: 4.12
Android NDK: r8b
OF: 0073


02-24 14:11:50.222: E/AndroidRuntime(19355): FATAL EXCEPTION: main
02-24 14:11:50.222: E/AndroidRuntime(19355): java.lang.RuntimeException: Unable to instantiate activity ComponentInfo{cc.openframeworks.androidEmptyExample/cc.openframeworks.androidEmptyExample.OFActivity}: java.lang.ClassNotFoundException: cc.openframeworks.androidEmptyExample.OFActivity

okay, I’ve made a lot of noise on the forums here today … the above issue is resolved.

I upgraded to android OF 0.7.4 (which is brand new) and NDK r8d and following the instructions in the readmet, all my activity classes are generated correctly and my example plays on my Nexus Phone as expected! Success!! Thanks to all who worked on this latest release!