ANDROID STUDIO & MAC OS (CATALINA) Could Not Determine Java version

hi, I tried to test Android Studio & mac on stable & latest build but I get this error:

Could not determine java version from ‘11.0.8’.

The project uses Gradle version which is incompatible with Studio running on Java 10 or newer.
See details at https://github.com/gradle/gradle/issues/8431
Possible solution:

  • Upgrade Gradle wrapper to 4.8.1 version and re-import the project

Should I downgrade my operating system to Sierra?

To Answer my own Question:

apparently open Frameworks is no longer compatible with “Any version of Android Studio”,

you need to use legacy version for example (3.1.4)

you can download it from here,

https://android-studio.en.uptodown.com/mac/download/1767310

ps:
///ofcourse I got other build errors, regarding creating a valid simulator…
but those are another story