Android Development on Linux 20.04?

Hi all, I have tried to get the Android build up and running on, but keep running into this error.

No tool chain is available to build for platform 'arm64-v8a':
  - Tool chain 'ndk-clang' (Clang): Could not determine Clang version: failed to execute clang -dM -E -.
  • I’m on Ubuntu 20.04.
  • I am using of_v0.11.0_android_release
  • I’m using the 15c NDK.
  • I have tried it using Android Studio 4.1.1 and 3.5.5.
  • I have tried updating the gradle files as suggested here.
  • I have no errors getting gradle to sync, but only have the problem when I build.

Can anyone recommend a working configuration?

My current solution is to install Android Studio 3.5.3 on macOS 10.15.7. There are some annoyances (like security around the old 15c NDK), but the solutions listed here work. I made no changes to any gradle files and it deployed easily on a Pixel 3a.

That said, if anyone has tips on what might be going on with Ubuntu 20.04, I’d’ really appreciate your thoughts.

I’m having the same problem on Ubuntu 20.10 with both Android Studio 3.5 and 4.1. If this is not resolved yet, we may consider a bug request.

Sorry for resurrecting an old thread. Just wanted to ask if anyone has had success with building for android on Ubuntu (or PopOS) with the current release since the last post. I am running into this exact error and have tried all the same fixes. Don’t have access to a Mac unfortunately.