Aliasing problems with postprocessing addons

Hey, I’ve just started trying some post processing addons such as ofxBloom and ofxPostProcessing but every time I get some aliasing problems when using the addons. Here are two pictures to compare.

I’ve tried using different versions of openGL and get the same issue, does anybody know where this could come from ? thanks

Hi, which filter are you applying in the images you share? It could be several different

I do not know the addons you mentioned, but check the sample resolution of the FBO.

This is some code that I have around in an old project

ofFbo::Settings settings;
settings.numSamples = 4; // try 8 if your GPU supports it.
settings.useDepth = false; // set it to true if you are going to use meshes and need the depth, otherwise false is ok for raymarching
settings.width = ofGetWidth();
settings.height = ofGetHeight();

BTW, ofxPostProcessing it has a fxaa pass, have you tried it?

aw its completely my bad, I thought I had tried different versions of GL but I hadn’t. It works fine with GL2 but not with GL3.2 the dev mentioned “Add support for ofGLProgrammableRenderer with version 150 shaders” in the todo list, I’m really sorry for wasting your time