addon guidelines

i wanted to ask i there are some guidelines regarding writing addons. i think it would be a good thing if addons would be consistent with OF itself.
should addon commands also have “of” as prefix? or rather a specific prefix?
do you have other internal coding style guidelines?
i am thinking of maybe contributing an addon if i have time to isolate the relevant classes…

best
joerg

hi -

we are working on this question right now and thinking about the best way for addons to work, especially with the OF framework (in terms of things like callbacks, includes, etc).

for naming conventions, in general the idea is to have either objects that have “of” prefixes:

**ofVideoPlayer
**
with functions that don’t have of prefixes, like

isFrameNew()

or in the cases of “C” style code, of prefixed functions:
**
ofDrawBitmapString();**

but I’m not sure if we see that spreading across all the addons as well. for now it is, but I think it’s possible that people can drop that convention if they want to (for example, the pro- libraries for processing, proMidi, proSVG, etc).

you can take a peak at some of the addons being implemented right now here:

http://svn.openframeworks.cc/browser/li-…-e=ofAddons

we are working very hard on alot of changes right now, and one of the big ones is to design a good system for addons along with documentation about how to work with them.

hope that helps - please post any other questions or comments, and if we can help at all with the addon you’re thinking of, please let us know.

thanks !!
zach