Adding external library to build? librealsense SDK (Ubuntu)


Im trying to compile openFrameworks with the RealSense sdk but have no luck. The addons for RealSense don’t work and I really dont understan why this should be so hard.

Has anyone done this? Or do you have any suggestions on how to solve it? The library is installed correctly and I’ve tried the sample code.

Got it working. Problem was that the gold linker(or what you call it) didn’t look in the /usr/local/lib folder.

Added -L/usr/local/lib/ to PROJECT_LDFLAGS in config.make

1 Like

thanks for this! what realsense model are you using and does ofxrealsense work with it?

Hi @MaxBjorverud,

I would also be interested to know which addon did you use finally. I’m also planning to use the the sensor RealSense D415 under Linux for a project.

I would really appreciate your help!

Hi! I didn’t use ofxRealsense. Just used the regular RealSense SDK! Worked ok but ended up using ofxNuitrack since I needed skeleton detection. Realsense got nothing…

Hi @MaxBjorverud. I finally got it working using ofxRealsense2 and installing the library compiling from the SDK. It’s a shame it doesn’t come with skeleton tracking like Kinect did.

1 Like

hello all. recently I tested with ofxRealSense2 addon by hiroMTB. but it does not have linux library and lastest SDK one. so I just forked and add linux libs with latest SDK. you can get here. it works and test on arch linux(manjaro).


Amazing, thanks!