Accelerated video in Raspberry Pi 3 Model B+

I’m searching for an optimal way to render an HD video using OF and raspberry Pi 3 B+.
I don’t have much practice with RBPi.
Q1: What would be the ideal setup?

I have followed the installation instructions for RBPi and most of the examples compile well. Except shaders.

Then I have tried ofxOMXPlayer but it gives an error:
undefined reference to symbol ‘eglCreateImageKHR’

has someone managed to run this addon or another solution for a video player in RBPi?

Hi

best is to use ofxOMXplayer on that pi3b+, you need to install of10 and raspbian Stretch, works great!

Thanks!
New question, how do you resolved the X11 problem? When I try to compile an example it reports error message. X11 not installed in RBp

Did you run the install_dependencies.sh script? It’s in the scripts/linux/debian folder, assuming you are on Rasbian.

Dont understand what you mean

ofxOMXplayer in of10 and stretch works, newer of and buster use glfw window not egl so dont work.

Yes. And it seems to be ok.
I’m using EGL, however, it still search for X11

compiling the graphic example I get this:
pi@raspberrypi:~/openFrameworks/examples/graphics/graphicsExample $ make run
HOST_OS=Linux
checking pkg-config libraries: cairo zlib gstreamer-app-1.0 gstreamer-1.0 gstreamer-video-1.0 gstreamer-base-1.0 libudev freetype2 fontconfig sndfile openal libcurl glfw3 rtaudio gtk±3.0
with PKG_CONFIG_LIBDIR=
[warning] ofAppEGLWindow: init(): X11 not availble on RPI yet, using a native window instead
[ error ] ofAppEGLWindow: getScreenSize(): tried to get display size but failed
[notice ] ofAppEGLWindow: setupRPiNativeWindow(): screenRect: 0x0
[notice ] ofAppEGLWindow: setupRPiNativeWindow(): windowRect: 0x0
[ error ] ofAppEGLWindow: setupRPiNativeWindow(): dispman_element == DISPMANX_INVALID
[warning] ofAppEGLWindow: getNativeDisplay(): window not initialized, returning NULL
[warning] ofAppEGLWindow: getNativeDisplay(): window not initialized, returning NULL
[notice ] ofAppEGLWindow: createSurface(): setting up EGL Display

  • failed to add service - already in use?
    /home/pi/openFrameworks/libs/openFrameworksCompiled/project/makefileCommon/compile.project.mk:190: fallo en las instrucciones para el objetivo ‘run’
    make: *** [run] Error 1

I’m using 2019-04-08-raspbian-stretch
Is that the correct one?

What of oF version are you using¿

of_v0.10.0, and also tried with of_v0.10.1
I will try now with raspbian-stretch-lite

Thanks for the suggestions, now it’s working after installing 2019-04-08-raspbian-stretch. I tried many Stretch versions and only this one works. I should have read the raspbian wikipedia before testing randomly.