about damiannz / wind project

Hi!

I am totally beginner in openframeworks, but I really need your help!

I have Mac OS X Lion.
Xcode 4.2, because 3.x version not working with Lion.
Openframeworks 0.062 and 0.07.
ofxPd added to addons folder.
even installed PureData.

But I can’t get to work Damian project “Wind” (https://github.com/damiannz/wind).

When I am trying to compile and run it, shows lot of errors :frowning:

I think, that I am doing everything right, but it is not working…

Please help me!

Do I have to downgrade to Snow Leopard? When I am trying to compile and run example apps, everything is working!

Thanks in advance!

Best regards,
Toms

the image you posted shows no errors, only warnings. errors are the red circular signs, warnings are yellow triangles.

if you post again with a picture of the errors maybe we can figure out what the problem is?

Hi!

Thanks for your reply!
Sorry for that!

Here is another shot.

Best regards,
Toms

sorry, you’re still only showing half the error messages, not giving relevant lines of code, etc.

this is what i see right now:

no member named 'startMessa…
Use of undeclared identifier 'sc…
Base of member reference is a…
Use of undeclared identifier ‘input’

from this, all i can tell is that Wind.cpp is making some references to things that are defined differently elsewhere. this could mean that damian forgot to commit some of his code, or that you have a mismatched addon, or… who knows.

more information would still help. but it’s also worth remembering that (i’m pretty sure) damian’s installation relies on some specific hardware too – if you don’t have the hardware, i’m not sure you’ll get the app ‘running’. i’m guessing he posted it mostly for educational or documentation purposes.

Hi!

Thanks kylemcdonald for your comment!
Now I will post detailed screenshots of the errors.
I contacted Damian and he was so kind to answer and pointed that there are no specific needs for hardware, any web camera will be fine.
But I still can’t get to work it.
I downloaded latest release of OF from github.com, added again ofxPd addon and no luck :frowning:

Maybe I really need to downgrade Mac Os and Xcode to get this work?
Damian could’t answer - works it with Xcode 4.2 or not…

Thanks in advance!

Best regards,
Toms

Pictures 1:

Picture 2:

Picture 3

Picture 4

Picture 5

Picture 6

for the errors involving “startMessage”, it looks like there might have been an api change in ofxPd. try changing it to startMsg as suggested and see if that helps.

for the messages involving ‘screen’ and ‘input’, if you look for their definition in the header:

  
  
#ifdef SCREEN  
WatterottScreen screen;  
WatterottInput input;  
#endif  
  

this means they’re not active unless you type:

  
  
#define SCREEN  
  

at the top of the header.

normally, they would also be surrounded by an #ifdef in the cpp, i’m not sure why it isn’t.

i’m also not sure what enabling SCREEN will do elsewhere, so it might be better to comment out the errors rather than add #define SCREEN. you’ll have to experiment.

Hi!

I tried to rename startmessage, but no luck :frowning:

I even downgraded to Leopard and Xcode 3.2., but it didn’t worked out also.

Hate to tell you, but Mac OSX version and Xcode versions have nothing to do with the build problems.

  1. Damian is building against an old version of ofxPd from the summer, as Kyle noted the api has changed. ofxPd is not yet stable but soon will be.

  2. There are some missing #ifdef statements in Damians code for when using the screen or not which cause it to fail.

I forked his project and can give you a buildable link soon.

Ok, it’s buildable on my fork: https://github.com/danomatika/wind I also made a pull request to Damian.

You will need the 0062 tagged version of ofxPd: https://github.com/danomatika/ofxPd/tree/0062

It runs but there is no sound and I don’t know how to use it. You will have to ask Damian …

Hi, danomatika!

I am very thankful for your time and kindness, but I still can’t get it to work :frowning:
I am very desperate :frowning:

I put back Lion and Xcode 4.2.
Downloaded openframeworks from https://github.com/danomatika/openFrameworks
Extracted it in /Toms/Documents/openframeworks
Build and ran the _DeployExamples located at: apps/devApps/_DeployExamples/deployExamples.xcodeproj
Downloaded https://github.com/danomatika/ofxPd/tree/0062 and putted it in /Toms/Documents/openframeworks/addons/ofxPd
Downloaded https://github.com/danomatika/wind and putted it in /Toms/Documents/openframeworks/apps/examples/windExample

Opened the project and tried to build and run, but no luck :frowning:

It says, that there is no core_c.h and core.hpp files, but I checked and they are!

I even contacted Damian and he was so kind, that sent me his ofxPd version, but also no luck :frowning: (the same error).

What I am doing wrong?!

Thanks in advance!

Best regards,
Toms

Hi!

Finally I have got got something!!! :wink:

It seems that I used wrong version of openframeworks.
Now I downloaded openframeworks from https://github.com/openframeworks/openFrameworks
And now I could compile project.
As you already mentioned, there is no sound, but about that I will contact Damian.
I hope he will help me.

Huge thanks for help! Really, thanks a lot!

Best regards,
Toms