a lot of errors.What i do?

hi to all.
Im beginner coder and i have question and i write about it.But no one write me back. Again,I ask and please tell me what i have to do,to do it right. I try to open examples but they dont work.I have this project files that i want to run,but still nothing.
I don`t know how to open them in code blocks.
I attach a screen shot that show the files and errors when i run them.
Can anybody help me.

it’s been a while since I touched codeblocks, but it seems you opened the .cbp file. you should open the .workspace file.

i have only this 3 files.Nothing else

please copy the emptyexample folder (in OF/apps) and put your changes there, or alteratively use the OF/scripts/createProjects.py script to create a new one. OF has pre-made codeblocks files which enable you to set up projects and compile OF quickly.

then i just have to rename the files like mine.Is that all?

hi again.
I rename in the code all names with the names of the files.but still nothing.
maybe i have to show you what i`m doing:
http://www.creativeapplications.net/tutorials/arduino-servo-opencv-tutorial-openframeworks/

Thank you for your time to help me.

is your OF folder tree correct? can you run the emptyExample?

yes i run it and i modified it.
but ofx ???
i use OF 0.71 latest

“but ofx ???”

… does this mean that your addon examples are not compiling?
Can you please post a picture of your folder structure ?

OK I do it right this time but still when it has to turn on the webcam is just black screen with these errors:

the warnings you’re getting in the console are telling you that ofSetColor() syntax has changed: i.e. if you want to the color to white you can do:

ofSetColor(255,255,255);

or

ofSetHexColor(0xffffff);

or

ofSetColor(ofColor::white)

for the black webcam: I don’t know what you’re trying to do, but did you try to adjust your threshold?

finally a suggestion: I may be wrong, but it looks like you’re trying to copy/paste stuff in your project until it works; it’s normally better to slow down, understand each step of what you’re trying to achieve, and slowly implement functionality one line at a time (trying to customize the examples you found to your real needs.)

Hi naus3a.
thank you for your advise.I try with both :
ofSetHexColor(0xffffff);
ofSetColor(255,255,255);

and this is the result with both:
black screen,i have one webcam,today i try with two.

i try to do this project:
http://www.creativeapplications.net/tutorials/arduino-servo-opencv-tutorial-openframeworks/

I can point you to 2 obvious problems:

  • in your console log you can read: “SETUP: device[5] not found… this means that the last device you can use is device[0]”

  • the CAN tutorial, on the other hand, says: “vidGrabber.setDeviceID(5); // this isn’t necessary if you’re only using one camera”

did you try commenting this line? if you look at the API reference in the wiki, you’ll find all the functions of your videoGrabber and you’ll learn how list the available devices. like we used to say on the old days: RTM, which stands for Read The Manual :slight_smile: (ok, I removed a letter from the acronym :wink: )

thanx again but why webcam is not starting on.

did you try to comments the vidGrabber.setDeviceID(5); line or to change it with vidGrabber.setDeviceID(0);?

if your computer has only 1 webcam with a device ID of 0 and you tell it to open device 5 it will give you an error.

THANK A LOT TO ALL,WHO HELP ME.
naus3a & jesses.co.tt
thank you!!!
If i have more question i know who to ask

So… that worked ?