A fix for OSX translocation

This question is in regards to the downloadable release of ml4a-ofx on OSX.

After download, none of the apps have access to the files in the data folder until each app is manually moved to another folder and then moved back. This is due to OSX now translocating the app as a security feature until they are moved.

One workaround is to bundle the data into the internal resources folder inside .app but this is problematic because all the apps have to share some large data files, which I’d prefer not to duplicate.

Is there any other workaround which makes this moving trick unnecessary so it behaves as expected?

1 Like

you can create a script that deletes the attributes and run it from a console. to delete the attributes you just need to run

xattr -cr root_path
1 Like

this appears to fix it, although it has to be done by the user (it seems), so i’m bundling it into the setup script. thanks!

I use to use a run.command file like this
.command file extension is a .sh file but it runs just clicking as a usual software on os x

#/bin/bash
NAME="Mareh201808"
APP="${NAME}Debug"
cd "$(dirname "$0")"
./${APP}.app/Contents/MacOS/${APP}

this is not pretty but I have console output and can open two instances of the same app easily when needed

PS: Not a fix but just a band aid solution for running softwares in different computers for now.

it’s almost 2021… is there a more elegant fix for this by now? I have made a very simple app and one of the benefits is that users can share and ‘import’ xml files into their data folder. So adding the data folder inside the app package won’t work.

I tried the ‘solution’ of using a dmg canvas but that did not work, the app is still translocated. So the only viable solution si to let the users copy the app outisde of the bin folder and copying it back?

hey @Maker_Bob
I am having the same problem today sending a dmg canvas file to a Catalina.
The same file it works fine on previous versions like High Sierra and Mohave(?).
I compiled the app on High Sierra.
Looking for a solution too.
I did not tried to bundle /data into the app, I’ll try