3d from single camera -

this stuff is nuts:

there is code here:

usage shot, love the eyes:

the logo is sweet! :

and this looks similar:

anyone interested in trying to helping to get this up and running? from a simple glance over the codebases it seems like it’ll take some collective efforts but it looks really promising.

take care!

That is next level!! super busy this month, if you still need an extra pair of hands in november I’ll definitely be up for it!

ohh man i was watching some of this stuff on youtube it is crazy. lets do it!

wow. yeah I saw this stuff a while ago and i’ve been hoping they would release the source soon. exciting!

kewl :smiley:

This is really awesome. Would love to contribute.

great! let’s try it …

i started digging around. The library itself seems pretty straightforward to compile, but the dependencies are pretty tricky. I’m still not 100% sure how im supposed to properly include things in xcode so that the path remains intact, but ill dig around a little more tomorrow. has anyone had any more luck?

Woah, this is some cool stuff. Count me in. I can see this being useful in loads of situations.

here’s a progress report on xcode -

was able to compile libcvd once, but on future compiles something broke and haven’t been able to walk my steps back to fix it, needless to say, this is a dependency, so good to break it out. I had to remove about 2-3 files to get this to compile, either glx types stuff, or ffmpeg type stuff, which I didn’t have the heart to digg around for.


this wont compile, but I guess with some putzing around, one could get it to compile again. Otherwise I’ll redo my steps.

with that libcvd compiled, I started to hack ptam, and got to about 100 errors :


all the includes seem to be working fine, it’s just stuff like template errors and undefined stuff.

I thought I’d throw it out there, in case anyone wants to try to widdle away at the errors. I’ll keep rolling with it :slight_smile:

take care!

ps my guess is that this is a 1-2-3 operation in linux, anyone want to give it a try ? you’ll need all the depencies, gvars, libcvd, toon…

Yes, I needed to modify the makefile to add lapack library to the linker settings but apart from that it compiles without problem.

:wink: (jealous…)


I’m not sure if you are interested to check out the VS2005 solution for this incredible PTAM

I made it ready to compile (plus the dependencies), you can just download the full solution here

Work fine for me on WindowsXP (still saving money for my first mac :frowning: )



@gatotkaca: Great work! I’ve downloaded your solution and it compiles nicely. I am able to run the calibrator but after I have saved the camera.cfg and when I run PTAM, it just stops working. I get stuck at the line:

ARDriver: Creating FBO…

Is it because I do not have a Graphics Card? I’m just using my Intel Graphics accelerator.


Referring to the README file. Maybe that is the case. but I’m not sure. I’ll check it again. See if I can reproduce the error.



For me it’s freezing even in the calibration. It has some uninitialized variables, I’ve manage to do the calibration but then it freeze again just after outputing the message about the FBO creation. Hasn’t had time to look at the code for the main program, but i’ll post if I find something.

yea, i’ve looked through the code and it seems to be calling some nvidia functions. Maybe you should try it out with an nvidia card.

Instant “hack” for using webcam instead of 1394cam

get it from here!



NOTE: hum…hope I have enough time to “wrap” it in OF…:slight_smile:

Firstly gatotkaca, AMAZING job on getting the program to work with a USB camera, I have been trying to make the port for a while now (I am a webcam dev noob, so a lot of studying was done). Wish I was able to find ewclib during my googling…

Now on for some of the problems I have been having,

I was wondering if anyone has run into an issue of EXTREMELY slow framerate for the camera calibrator. I am clocking in with about 1 fps, which is obviously abysmal.

Secondly, it seems that I am unable to register the click events on the OpenGL menu in the window. Well, the events are registered, but nothing essentially happens when I click on the buttons.

If anyone else has run into problems like these, it would be of tremendous help. Thanks!