2.1 not working

it seems it’s a known issue:

http://groups.google.com/group/android-ndk/browse-thread/thread/ceac4dd0703dea5d
http://code.google.com/p/android/issues/detail?id=14351
http://code.google.com/p/android/issues/detail?id=16008

actually 2 issues they solved one but there’s another one, compiling the ndk from their git solves the first one but not the second.

Unlikely, but does using the Crystax r5 NDK work?

don’t think so, there’s nothing related in his issue tracker:

http://www.crystax.net/trac

and cannot really test it, don’t have a 2.1 device.

EDIT: was looking at the opened issues, it seems he has already fix it:

http://www.crystax.net/trac/ticket/44

it’s incredible that one guy is faster solving issues than the whole google android team.

So by now use crystax instead of the official ndk. will update the instructions