0.9.4 Release Candidate 1


#42

you are in osx right?


#43

Yes…

Just checked it again I did quit QT, ./install_template.sh, even source ./install_template.sh, relaunch QT, imported another addon example… Same problem

BTW of_root is
property string of_root: '../../..'

And my application is right under myApps


#44

yes i’m testing in osx now and i’m seeing the same problem it was working fine in linux. i’m looking into it


#45

can you edit libs/openFrameworksCompiled/project/qtcreator/modules/of/helpers.js and change line 212 from:

sources = sources.concat(Helpers.findSourcesRecursive(addon + '/libs'));

to

sources = sources.concat(findSourcesRecursive(addon + '/libs'));

and check if that fixes it?


#46

No, same problem (I deleted the previous .qbs project file and reimported an addon example)


#47

that’s really strange that solved it for me, i’ll fix that in the next release anyway


#49

Which version of osx are you using ? Me it’s 10.5.5 - Could the find shell command have changed ? I can’t get any information about it, because there is no --version or -v option available


#50

i’m on 10.11 but i doubt it’s related to find, that command has probably have the same syntax for decades in unix. i have another computer with 10.10 or 10.9 i’ll give it a try there tomorrow


#51

Ahhh. I believe we now only support OS X 10.8 or OS X 10.9 or newer depending on the release.
OS X 10.5.5. will definitely be too old for OF v0.9 and above.


#52

My bad, it’s 10.10.5, not 10.5.5 :blush:

I could try to help, but how can I console.log in .qbs files ? I tried in several places, there is no error but nothing is displayed in the General Messages panel of Qt Creator…


#53

yes there’s no easy way to log the errors in qtcreator, the easiest is to throw an exception with whatever you want to see, like throw path will show the contents of that variable in issues.


#54

Got it ! There is a small typo in the modification you suggested

it’s findSourceRecursive instead of findSourcesRecursive

And tadada ! It works fine ! Happy !


Missing boost on osx 0.9.7 release
#55

oh, great i’m running osx on a virtual machine and had to type it by hand cause copy paste didn’t work from the vm.

anyway i’m preparing a 0.9.5 to fix this and a couple of problems with latest ubuntu version that has just been released.