0.9.0 Release Candidate 1


#44

I added the /mingw32 directory to the path variable, cleaned and compiled the emptyExample again. After adding .exe to the file and starting, windows gives me the error:

The library is present in the folder, and I’m running Windows 8 Pro 64 bit. Any ideas whats missing?


#45

Do you mean windows 7 or 8? that’s working for me fine. i’ll try to install everything from scratch later to see if i’m missing some step


#46

I’m sorry, I meant Windows 8 (fixed that typo above). I’d appreciate a lot if you could do that, thanks. I might try the same.


#47

That is correct, as of OF 0.9.0 only Visual Studio v140 will compile as older versions will give you an error that the MSVC version is incorrect. That being said you can use older versions of Visual studio so long as the compiler uses the correct toolset which can be configured in the platform toolset in the properties. VS2015 has some pretty nice feature upgrades though so I don’t know why you would use the older IDE anyways :laughing:


#48

I reinstalled msys2 and ran the config script again, too. It doesn’t run through in one go, but must be started 2-3 times until all tasks are resolved, due to missing resources/connection problems. I then compiled the emptyExample project again for last night’s built, and got a similar error.

On the cmd line:
C:/msys64/home/…/of_v20150826_win_cb_nightly/of_v20150826_win_cb_relea se/apps/myApps/emptyExample/bin/emptyExample.exe: error while loading shared lib raries: ?: cannot open shared object file: No such file or directory

When starting from the explorer, a prompt tells me that “libfmodex.dll” is missing from my computer. “which libfmodex.dll” in the msys2 shell doesn’t find the library, either.

Any ideas? Shouldn’t this one come with mingw?


#49

Just downloaded the iOS version. Can’t launch any example. Even the emptyExample in the apps folder doesn’t launch.

Not sure if this is a bug or I am missing something.

Apple Mach-O Linker Error:

“_fchmodat”

and

linker command failed with exit code 1 (use -v to see invocation)

I am on 10.8. btw…


#50

can you check the latest nightly build? there’s been several fixes since we released RC1


#51

hey arturo, that’s what i did first… reported the bug: https://github.com/openframeworks/openFrameworks/issues/4307


#52

Are we doing an RC2? Might be a good time


#53

there’s still some remaining issues marked as 0.9 related to the codebase i think until those are closed we shouldn’t do another release. @zach is also working on the new PG, once that’s ready we’ll do an RC2


#54

I should have a version of the PG to test by the end of the weekend. This is a screenshot of the current UI

it’s got tools for generating, updating and updating multiple projects and it wraps a command line tool which you can setup (via your shell) as well to handle interacting with projects.

I will post up zips to test for windows / mac (and hopefully linux) in the next day or two, eyeballs and feedback really appreciated (the front end is done in html / css so it’s also easy to change).


#55

ouch ! huge enhancement !
great.


#56

here’s a version to test on OSX (other platforms coming shortly)

install it in the current master on github like:

it also may work on 0.8.4, I haven’t tested it there…

it has a regular mode and and advanced mode, in the advanced mode you can update multiple files (be careful!) recursively.

curious for feedback, we are trying to add drag and drop support and opening of projects / folders from this tool once you’ve generated or update them.


#57

Just tried it with ofxTouchPad and got this error when I tried to open the xcode project:

– on the develop branch https://github.com/bakercp/ofxTouchPad/tree/develop + https://github.com/bakercp/ofxPointer/tree/develop

(xcode 6.4, osx 10.10, master branch, etc).


#58

Also tried it with ofxHTTP (https://github.com/bakercp/ofxHTTP/tree/develop) e.g. tried to update the example_basic_client project and it included ofxHTTP but ignored the ADDON_DEPENDENCIES in the addon_config.mk. The command line version appears to do this too though, so I don’t think it’s a gui problem. The gui is really nice!


#59

@bakercp thanks! It appears that the command line tool in this app wasn’t build
with this PR (which should be merged but hasn’t been yet ) which fixes this issue:

https://github.com/openframeworks/openFrameworks/pull/4170

I’m digging into it now and will post something else tomorrow to try…

I’ll take a look at ADDON_DEPENDENCIES… I know that is being parsed out but I don’t know if it’s doing anything with those at the moment.


#60

What GUI framework is used for the project generator tool?


#61

It’s simply HTML5 code rendered with webkit and nodejs, wrapped into a standalone app with Electron. For information, the HTML gui then calls the commandLinePG with the right arguments.


#62

Yup, I found the source code and I saw what they are using. I thought they are using openframeworks too, but from what I could find, it’s not really possible (comfortable) to integrate OF with Electron. I am looking into Awesomium at the moment


#63

I’m new to OF, and am looking for status on the release of OF 0.9.0. This thread was started in August, with the thought that it would be released in a couple weeks. It’s now been two months. :slight_smile: http://openframeworks.cc/download/ still shows 0.8.4 as the latest.

I don’t see any other announcement thread on this subject. Is there a different means of communicating such topics?

I am looking at the latest changes at https://github.com/openframeworks/openFrameworks, and playing around with things there. However, judging from the amount and rate (and types) of changes going in lately, it seems the release of 0.9.0 is not as near as was announced. I don’t have any issue with that. Just looking for some status.

Thanks!
-Todd