0.9.0 Release Candidate 1


#22

I don’t think it did:
here’s the output:

https://gist.github.com/gepatto/5461103df79c1d9e3cd0


#23

are you running the install_dependencies from scripts/linux/debian_armv6l ?

and if so can you post what’s the output from:

cat /etc/os-release | grep VERSION= | sed "s/VERSION\=\"\(.*\)\"/\1/"

#24

outputs:
7 (wheezy)

I’m running from scripts/linux/debian
(There is no directory debian_armv6l in the armv7l download, just debian)
oh and I am using a raspberry pi 2 (armv7)


#25

oh, ok i think it should be fixed now in master or tomorrow’s nightly but if you want to give it a try you can add:

OS_CODENAME=$(cat /etc/os-release | grep VERSION= | sed "s/VERSION\=\"\(.*\)\"/\1/")

if [ "$OS_CODENAME" = "7 (wheezy)" ]; then
    echo "detected wheezy, installing g++4.8 for c++11 compatibility"
    apt-get install g++-4.8
fi

at the end of the install_dependencies script


Raspberry Pi 2 Setup Guide (0.8.4)
#27

I tried a clean install of raspbian wheezy,
and now it does find and install g++4.8. (with the above code added to install_dependencies)
However it will leave 4.6 as the default. so either call g+±4.8 manually in the makefile
or I guess use something like

sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.6 20
sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.8 50
sudo update-alternatives --install /usr/bin/g++ g++ /usr/bin/g+±4.6 20
sudo update-alternatives --install /usr/bin/g++ g++ /usr/bin/g+±4.8 50

to prefer version 4.8


#28

thanks so much, we’ll include it in the next release


#30

Hello,

Is there some instructions on how to use 0.9.0 with MinGW and MSYS? Or a guide on how to migrate projects ?
I used to work with CB/MinGW but I don’t know how to use the new method… It’s not unzip and run anymore…

Is MSYS2 mandatory or only useful to download/upgrade libs ?

Thanks for the help


#31

I’m about to dive in and test this out. Looking forward to it. What latest version of Visual Studio is now supported? Thanks!


#32

Hi,

Today I tried compiling. It worked, sort of. It made an executable, but the executable had no extension so I had to add .exe to the end of it. After that I tried running it and it said it was missing a bunch of DLLs, and I checked the directories and the DLLs it was missing don’t exist. So I cant run the executable that was compiled. Also make it have an extension when it’s compiled please, I don’t want to add .exe to every file I compile.


#33

Which dlls it missed?


#34

I’m using Visual Studio 2015 Community and it’s working well. As far as I can tell, older versions of VS are not supported.


#35

Thanks. I just installed it, and it’s working great on the first few examples. I’m loving oF + VS15. Such a nice upgrade.


#36

libboost_filesystem-mt, libboost_system-mt, libcairo-2 and LIBEAY32 were not found and do not exist.


#37

For quick and “dirty” workaround you can add MSYS2 search paths like described here.

For long-term solution… I guess makefiles in openFrameworks point to dlls since compilers prefer to choose dynamic libraries by default, and when app is executed it can’t find those dlls and dependent dlls in app’s folder. I think one can fix this in makefiles by pointing to static libraries directly, like “$(MSYS2_ROOT)/mingw32/lib/libboost_filesystem-mt.a”? @arturo?


#38

i think some later commit has messed up the mingw makefiles and it’s detecting the platform as linux so it’s not adding the .exe and not copying the correct dlls. i’ll take a look


#39

There’s a translation discrepancy with 0.9.0 (github master) and one of my addons.
https://github.com/charlesveasey/ofxDomemaster/tree/master

The fix was to translate the loaded models (ply):
https://github.com/charlesveasey/ofxDomemaster/commit/4da4e93d248eeae2dd196067456a43c11fbc0383

Not sure if the difference was intentional. Any idea?


#40

I tried to compile the emptyExample from today’s nightly built and ran into the same library issues as @BananasGoMoo . I also tried to compile the 3DPrimitives example. It works fine for a while, the the building process stops with loads of missing references. There seem to be links to absolute paths that the system doesn’t understand:

C:/msys64/home/worldwindow/of_v20150824_win_cb_nightly/of_v20150824_win_cb_release/libs/videoInput/lib/win_cb/videoInputLib.a(video Input.o): In function ZN11videoDeviceC2Ev': C:/Users/theo/Documents/GitHub/videoInput/videoInputSrcAndDemos/libs/videoInput/videoInput.cpp:217: undefined reference to__gxx_p ersonality_sj0’
C:/Users/theo/Documents/GitHub/videoInput/videoInputSrcAndDemos/libs/videoInput/videoInput.cpp:217: undefined reference to _Unwind _SjLj_Register' C:/Users/theo/Documents/GitHub/videoInput/videoInputSrcAndDemos/libs/videoInput/videoInput.cpp:231: undefined reference to_Unwind _SjLj_Resume’
C:/Users/theo/Documents/GitHub/videoInput/videoInputSrcAndDemos/libs/videoInput/videoInput.cpp:231: undefined reference to `_Unwind _SjLj_Unregister’


#41

Does this functionality cover opengl es? Can we export ofAndroid games to run on the web?


#42

webgl is mostly opengles and the programming practives to make things
run smoothly are similar, so it’s even more compatible with anything
that is already running on an opengles device


#43

@BananasGoMoo @chris_abyi the problem is that i forgot to mention one step to the installation for msys2. the libraries come with some dlls that the app need to run that are in /mingw32/bin so you need to add that path to your PATH environment variable.

if you are in the msys2 console you can just do:

export PATH=$PATH:/mingw32/bin

but you would have to do it every time you start and wouldn’t be able to run applications from explorer.

you can also add the equivalent PATH c:\msys64\mingw32\bin to your PATH environment variable in windows:

http://geekswithblogs.net/renso/archive/2009/10/21/how-to-set-the-windows-path-in-windows-7.aspx
http://www.computertutorialsonline.com/change-path-environment-variable-in-windows-8

The problem with the .exe extension is now fixed in master and will be in tonight’s nightlies